[RESOLU] Aucun utilisateur au démarrage de Windows XP

La section des versions NT, 2000, et XP de windows : informations, problèmes, questions, avis ou dépannages y trouveront leur place.

Modérateur: Modérateurs

[RESOLU] Aucun utilisateur au démarrage de Windows XP

Messagepar Santi » 02 Avr 2008 19:46

Bonsoir tout le monde!

Mon problème est le suivant :
Lorsque Windows démarre, une fois arrivé à l'écran de sélection des utilisateurs (qui ne s'affichait pas avant, car j'ai un seul utilisateur et je n'avais jamais activé cette option) Windows me demande de choisir un utilisateur, mais il n'y a rien. Juste le bouton pour éteindre/redémarrer l'ordinateur.
Après avoir cherché pendant des semaines sur internet, j'ai essayé les choses suivantes :
Premièrement, j'ai fait 3 fois Ctrl+Alt+Del. J'arrive bien sur une boîte pour rentrer mon mot de passe, sauf que j'en ai jamais mis. J'ai essayé en laissant vide (pour le compte principal et le compte Administrateur) et avec toutes les propositions trouvées sur internet. Marche pas. J'ai aussi essayé avec tous les modes sans échec possible, j'ai le même écran de sélection vide...
Ensuite, j'ai essayé d'aller voir le mot de passe donné par Windows et éventuellement le modifier avec [url="http://home.eunet.no/~pnordahl/ntpasswd/"]ntpasswd[/url] et j'obtiens le message d'erreur suivant :
Code: Tout sélectionner
===== chntpw Edit User Info & Passwords ====

Cannot find usernames in registry! (Is this a SAM-hive?)
 
Select: ! - quit, . - list users, 0x<RID> - User with RID (hex)
or simply enter the username to change: [Administrator]

J'ai pas trouvé de solution sur internet à cette erreur et j'essaie donc d'ouvrir ce fichier SAM (qui contient les mot de passe de Windows) avec Ophcrack, logiciel open source. Apparemment, il ne l'aime pas trop, vu qu'il refuse de l'ouvrir (le fichier serait mal hashé, ou je ne sais trop quoi....)
Ensuite, sur un forum je tombe sur un petit logiciel (pour modifier les mots de passe, créer un utilisateur ayant les privilèges administrateur, etc.) à intégrer au boot disc BartPE. Je me grave donc ce CD et quand j'essaie de faire marcher le plugin, il m'envoie un message d'erreur que l'assistance sur le forum n'arrive pas à m'expliquer.

En désespoir de cause, je me tourne donc vers vous...
Est-ce que vous avez une idée de ce que je pourrais faire (le formatage ne sera fait qu'en cas d'échec retentissant)?

Merci d'avance :)
Dernière édition par Santi le 09 Avr 2008 21:33, édité 2 fois.
Avatar de l’utilisateur
Santi
 
Messages: 13
Inscription: 17 Déc 2006 14:06
Localisation: Genève

Re: Aucun utilisateur au démarrage de Windows XP

Messagepar Dell » 02 Avr 2008 20:53

Hello Santi

as-tu essayé de faire une restauration système :?:

_DELL_
Windows 10/ 64 Bits, FireFox, F-Secure,
Internet InOne M , SwisscomTv InOne M, Téléphonie IP InOne M, Mobile InOne S
Avatar de l’utilisateur
Dell
Modérateur
Modérateur
 
Messages: 9462
Inscription: 16 Oct 2002 16:57
Localisation: Aigle (Suisse)

Re: Aucun utilisateur au démarrage de Windows XP

Messagepar Santi » 02 Avr 2008 21:33

J'y ai pensé mais je n'ai pas trouvé moyen de le faire sans me logguer dans une session...
J'ai aussi essayé de mettre les derniers paramètres fonctionnels et ça ne marche pas.
Mais si y'a moyen de faire une restauration système sans se logguer, je suis preneur! :)
Avatar de l’utilisateur
Santi
 
Messages: 13
Inscription: 17 Déc 2006 14:06
Localisation: Genève

Re: Aucun utilisateur au démarrage de Windows XP

Messagepar Achille1er » 03 Avr 2008 07:23

Si le double CTRL ALT DEL donne encore l'accès au panneau de login classique (en mode texte), un login en tant qu'administrateur ne fonctionne plus non plus ?
Dernière édition par Achille1er le 03 Avr 2008 10:12, édité 1 fois.
Avatar de l’utilisateur
Achille1er
Super Libellulien
Super Libellulien
 
Messages: 2533
Inscription: 30 Mai 2005 07:46
Localisation: Zotrland

Re: Aucun utilisateur au démarrage de Windows XP

Messagepar nadirxyz » 03 Avr 2008 09:32

Si ton CD de boot est doté d'un explorateur de fichier, essaye l'opération suivante:

1)Accède au dossier C(ou quel que soit ton disque dur):\WINDOWS\system32\config

2)Crée un dossier nommé "backup" et place dans ce dossier le fichier nommé SAM (prends garde à sélectionner celui qui ne possède pas d'extension)

3)Accède au dossier C:\WINDOWS\repair et copie le fichier sam (sans extension à nouveau) dans le dans le dossier C:\WINDOWS\system32\config
(je ne sais pas si cela à un effet mais il vaut mieux le renommer en SAM)

4)démarre ton ordinateur et effectue une restauration système(choisir de préférence une date antérieure de 2 jours à l'apparition de ton problème).

Voilà, ça devrait marcher!!
nadirxyz
 
Messages: 2
Inscription: 03 Avr 2008 09:18

Re: Aucun utilisateur au démarrage de Windows XP

Messagepar Santi » 03 Avr 2008 10:42

Achille1er a écrit:Si le double CTRL ALT DEL donne encore l'accès au panneau de login classique (en mode texte), un login en tant qu'administrateur ne fonctionne plus non plus ?

Non plus et j'ai essayé avec le mot de passe vide et toutes les variantes farfelues qu'on trouve sur internet.
nadirxyz a écrit:Si ton CD de boot est doté d'un explorateur de fichier, essaye l'opération suivante:

1)Accède au dossier C(ou quel que soit ton disque dur):\WINDOWS\system32\config

2)Crée un dossier nommé "backup" et place dans ce dossier le fichier nommé SAM (prends garde à sélectionner celui qui ne possède pas d'extension)

3)Accède au dossier C:\WINDOWS\repair et copie le fichier sam (sans extension à nouveau) dans le dans le dossier C:\WINDOWS\system32\config
(je ne sais pas si cela à un effet mais il vaut mieux le renommer en SAM)

4)démarre ton ordinateur et effectue une restauration système(choisir de préférence une date antérieure de 2 jours à l'apparition de ton problème).

Voilà, ça devrait marcher!!

Merci beaucoup, je vais essayer demain je pense.
Je vous tiens au courant! :)
Avatar de l’utilisateur
Santi
 
Messages: 13
Inscription: 17 Déc 2006 14:06
Localisation: Genève

Re: Aucun utilisateur au démarrage de Windows XP

Messagepar Santi » 05 Avr 2008 18:15

Grâce à cette astuce miraculeuse ça marche!!! Merci beaucoup! :-D
Sauf que j'ai encore un petit problème...
Quand je veux faire la restoration du système, au moment de choisir la date, je ne peux pas changer de mois. Le click sur la flèche pour aller en arrière ne donne rien... Des idées?
Je crois que si ça continue je vais licencier mon ordinateur... :P
Avatar de l’utilisateur
Santi
 
Messages: 13
Inscription: 17 Déc 2006 14:06
Localisation: Genève

Re: Aucun utilisateur au démarrage de Windows XP

Messagepar nadirxyz » 05 Avr 2008 22:19

Si tu ne peux pas changer de mois cela signifie sans doute qu'il n'y a pas de point de restauration pour le mois précedent. Windows les a sans doute supprimés par manque d'espace...Tu peux vérifier que ces points n'existent pas grace au logiciel RestorWIN (Google est ton ami!)
nadirxyz
 
Messages: 2
Inscription: 03 Avr 2008 09:18

Re: Aucun utilisateur au démarrage de Windows XP

Messagepar Santi » 05 Avr 2008 23:05

nadirxyz a écrit:Si tu ne peux pas changer de mois cela signifie sans doute qu'il n'y a pas de point de restauration pour le mois précedent. Windows les a sans doute supprimés par manque d'espace...Tu peux vérifier que ces points n'existent pas grace au logiciel RestorWIN (Google est ton ami!)

Ben j'en avais puisque j'en ai lancé une...
Sauf que lors du redémarrage de l'ordinateur "restauré" j'ai eu un message comme quoi rstrui.exe ne pouvait être lancé à cause d'une .dll... J'ai "réussi" à réparer ça, mais quand j'ouvre ça me donne ça. Et je pense que même si je n'avais pas de point de restauration, les mois s'afficheraient, mais vides...

Mais je vais essayer avec RestorWIN, merci beaucoup. :)

EDIT : J'ai regardé avec RestorWIN et apparemment, Windows a décidé d'effacer mes anciens points de restauration...
Sauf que maintenant, j'ai plein de problèmes de .dll avec plein de programmes...
Vais essayer de réinstaller mes programmes ou à la limite de réparer Windows...
Quelqu'un sait si la réparation de Windows peut entraîner une perte des données et si les logiciels doivent tous être réinstallés?

Merci d'avance. :supers:
Avatar de l’utilisateur
Santi
 
Messages: 13
Inscription: 17 Déc 2006 14:06
Localisation: Genève

Re: Aucun utilisateur au démarrage de Windows XP

Messagepar GSTAR » 07 Avr 2008 21:31

.
Dernière édition par GSTAR le 20 Nov 2008 01:39, édité 1 fois.
GSTAR
Libellulien Junior
Libellulien Junior
 
Messages: 383
Inscription: 03 Juin 2005 11:59
Localisation: Lausanne VD - Suisse

Re: [RESOLU] Aucun utilisateur au démarrage de Windows XP

Messagepar Santi » 09 Avr 2008 21:34

Bon, alors j'ai fini par faire une réparation Windows en ayant sauvegardé toutes mes données. J'ai heureusement pas eu de problème et la sauvegarde n'a servi à rien.
Les choses vont mieux!

Merci pour votre aide! :supers: :supers: :supers:
Avatar de l’utilisateur
Santi
 
Messages: 13
Inscription: 17 Déc 2006 14:06
Localisation: Genève


Retourner vers Windows NT, 2000, XP

Qui est en ligne

Utilisateurs parcourant ce forum: Aucun utilisateur enregistré et 0 invités