[résolu] Calculer la même colonne dans excel

Posez ici toutes les questions concernant un ou plusieurs logiciels, payants ou gratuits. Pour les demandes spécifiques aux systèmes d'exploitation, passez plutôt par les sections dédiées.

Modérateur: Modérateurs

[résolu] Calculer la même colonne dans excel

Messagepar anasie » 26 Avr 2015 11:55

Bonjour,
J'ai besoin de calculer toujours la même colonne dans excel même si j'ajoute une colonne avant la colonne ajouter doit faire partie des colonne calculée.
Exemple: =SOMME($O4+$S4+$W4+$AA4) si j'ajoute une colonne avant O, celle-ci doit être remplacé par la nouvelle et AA supprimé Je dois calculer toujours que 4 colonnes

J'ai épuisé mon quota de recherche sur le net j’espère que vous pourrez m'aider

Salutations
Dernière édition par anasie le 03 Mai 2015 11:56, édité 1 fois.
Avatar de l’utilisateur
anasie
Libellulien Junior
Libellulien Junior
 
Messages: 277
Inscription: 13 Jan 2004 21:22
Localisation: Suisse Neuchâtel

Re: Calculer la même colonne dans excel

Messagepar Renard » 26 Avr 2015 15:55

Salut
Ton explication n'est pas très claire.
Peux tu joindre une copie d'écran de ton tableau excel ?
Bien amicalement,
Renard
Avatar de l’utilisateur
Renard
Super Libellulien
Super Libellulien
 
Messages: 2350
Inscription: 18 Juin 2005 16:31
Localisation: Lausanne

Re: Calculer la même colonne dans excel

Messagepar dafy » 26 Avr 2015 19:34

Bonsoir,
Avec des fonctions simples ce n'est pas possible à mon avis. La formule ne peut deviner que tu ajoutes une colonne et qu'en plus suite à cela il faut enlever à l'autre bout.
Avec des macros peut-être ou VBA mais je ne maitrise pas.
Quel est le but et le besoin il est possible de te proposer autre chose à condition de savoir précisément quoi.
@+
"Tout est relatif, et cela seul est absolu."
Avatar de l’utilisateur
dafy
Maître Libellulien
Maître Libellulien
 
Messages: 870
Inscription: 13 Fév 2005 21:53
Localisation: Toonville

Re: Calculer la même colonne dans excel

Messagepar phanou » 28 Avr 2015 11:34

Hello,

Pourquoi ne pas le faire manuellement?
Tu as ta formule: =SOMME($O4+$S4+$W4+$AA4).
Tu insert une colonne avant O (qui va devenir O...), donc ta formule deviens automatiquement: =SOMME($P4+$T4+$X4+$AB4)
Tu double cliques sur la cellule ou tu as ta formule et soit tu remplace $AB4 par $O4 soit tu déplace le petit carré de couleur...
Ta formule devient =SOMME($P4+$T4+$X4+$O4)

Elle additionne ta nouvelle cellule et ne prends plus en compte la dernière....

Dans les conditions que tu expliques (nous n'avons pas tous les paramètres), c'est le meilleur rendement Efficacité/rapidité :)
A force de disperser notre savoir au vent, le vent finira par être plus sage que nous... (Phanou)
"Les citations trouvées sur Internet ne sont pas toujours précises - Abraham Lincoln"
Avatar de l’utilisateur
phanou
Modérateur
Modérateur
 
Messages: 2593
Inscription: 29 Avr 2004 18:53
Localisation: dans la lune, le plus souvent

Re: Calculer la même colonne dans excel

Messagepar willycagnes » 28 Avr 2015 17:44

bonjour,

voici mon fichier démo pour résoudre ton problème
avec et sans macro à tester

avec la formule toute simple:
=A1+DECALER(A1;0;1)+DECALER(A1;0;2)+DECALER(A1;0;3)

http://cjoint.com/?EDCr05tflCB
Dernière édition par Hapax le 28 Avr 2015 18:02, édité 1 fois.
Raison: merci de ne pas racoler pour d'autres forums,svp...lien supprimé
Avatar de l’utilisateur
willycagnes
 
Messages: 3
Inscription: 28 Avr 2015 17:35

Re: Calculer la même colonne dans excel

Messagepar anasie » 03 Mai 2015 10:38

Bonjour,

Merci à tous pour vos contributions, désolé pour ma réponse tardive.
Je vais tester ta solution willycagnes et vous tiens au courant

Merci
Avatar de l’utilisateur
anasie
Libellulien Junior
Libellulien Junior
 
Messages: 277
Inscription: 13 Jan 2004 21:22
Localisation: Suisse Neuchâtel

[Résolu] Re: Calculer la même colonne dans excel

Messagepar anasie » 03 Mai 2015 11:55

Merci Willycagnes ça fonctione.....

Bon dimanche
Avatar de l’utilisateur
anasie
Libellulien Junior
Libellulien Junior
 
Messages: 277
Inscription: 13 Jan 2004 21:22
Localisation: Suisse Neuchâtel

Re: [résolu] Calculer la même colonne dans excel

Messagepar phanou » 04 Mai 2015 14:34

:-D Merci willycagnes , je vais étudier cette formule (et ton fichier) de plus près !
A force de disperser notre savoir au vent, le vent finira par être plus sage que nous... (Phanou)
"Les citations trouvées sur Internet ne sont pas toujours précises - Abraham Lincoln"
Avatar de l’utilisateur
phanou
Modérateur
Modérateur
 
Messages: 2593
Inscription: 29 Avr 2004 18:53
Localisation: dans la lune, le plus souvent


Retourner vers Software - Logiciels

Qui est en ligne

Utilisateurs parcourant ce forum: Aucun utilisateur enregistré et 0 invités