Caractères accentués remplacés par des <?>

Posez toutes les questions concernant internet en général et son utilisation, les comptes Email, le chat, les opérateurs téléphoniques et fournisseurs d'accès, FTP etc...

Modérateur: Modérateurs

Re: Caractères accentués remplacés par points d'interrogati

Messagepar Hapax » 06 Déc 2011 15:06

arnob a écrit:le + simple pour tes problèmes est d'arrêter de visiter clubic.com et venir chez libellules, laisse toi guider par la force/fluide invisible présente dans ton ordi

:lol: je sais pas si çà va vraiment l'aider...
Si vous pensez que la technologie peut résoudre vos problèmes de sécurité, alors vous n’avez rien compris aux problèmes ni à la technologie. ( Bruce Schneier )
Avatar de l’utilisateur
Hapax
Modérateur
Modérateur
 
Messages: 11564
Inscription: 16 Juil 2008 10:45

Re: Caractères accentués remplacés par points d'interrogati

Messagepar fuzzystone » 06 Déc 2011 21:37

Bonsoir les amis,

C'est sûr que sur Clubic il n'y a que des nullards : 21 lectures, 0 réponses. Et je ne parle même pas de 01net : 36 lectures, 0 réponses. Mais maintenant pour vous, le vrai défi ne va pas être de donner des réponses pour lesquelles je vous suis déjà très très reconnaissant) : il faut résoudre le problème! Mlheureusement ce que vous venez de me proposer n'a rien changé...

Est-ce que le fait que je trouve un encodage adéquat sur Safari (Western European) vous inspire? Ca semble bien être un problème d'endocage (ou plutôt de décodage), non? Dans le corps des pages web, je n'ai que très rarement eu ce problème, et uniquement dans des sites exotiques.

A+ j'espère. Fuzzy.
fuzzystone
Libellulien
Libellulien
 
Messages: 94
Inscription: 05 Jan 2007 15:22

Re: Caractères accentués remplacés par points d'interrogati

Messagepar Falkra » 06 Déc 2011 22:24

Clubic ou libellules, la question n'est pas là.

Qu'est-ce qui tourne avec la machine ? Antivirus, Firewall, autres ?
Avatar de l’utilisateur
Falkra
Admin libellules.ch
Admin libellules.ch
 
Messages: 25778
Inscription: 30 Jan 2005 14:44
Localisation: 127.0.0.1

Re: Caractères accentués remplacés par points d'interrogati

Messagepar fuzzystone » 06 Déc 2011 22:53

Avast comme antivirus, firewall de Windows 7 64 bits, ménage automatique par TuneUp Utilities 2010. Périodiquement, Windows Defender et Malewarebytes' Anti-malware. Ceci depuis 1 an, l'âge de la machine.
fuzzystone
Libellulien
Libellulien
 
Messages: 94
Inscription: 05 Jan 2007 15:22

Re: Caractères accentués remplacés par points d'interrogati

Messagepar Babyl » 12 Déc 2011 16:08

Bonjour
en fait,la question que je me pose concerne le caractère sélectif de ce "bug"...pourquoi tel site et pas l'autre ?
un problème généralisé est plus facile à cerner...


Parce que clubic utilise le charset iso, alors que libellules le charset utf-8
Chez moi comme vous tous nos navigateurs font bien bien l'interprétation de chaque charset mais chez fuzzystone, il semble qu'il y ai un problème avec l'interprétation du charset iso.
Je suppose que tous les sites où fuzzystone constate ce problème, c'est le charset iso qui est utilisé.

@ +
Babyl
Avatar de l’utilisateur
Babyl
Libellulien Junior
Libellulien Junior
 
Messages: 155
Inscription: 21 Juil 2011 13:16

Re: Caractères accentués remplacés par points d'interrogati

Messagepar Babyl » 12 Déc 2011 17:19

En fait Cublic est en iso il faut cocher iso, alors que tu as utf-8 pour la page cublic sur ton image en page 1.

Avec clublic tu devrais avoir ça pour avoir tes accents
Image
Donc quand tu es sur clubic coche iso à la place de utf8;

Et ensuite reviens sur libellule regarde de nouveau et libellule est en utf-8 tu devrais avoir utf-8 sans ne rien toucher.

Ce que tu dois voir avec libellule :
Image

avec ça tout devrait rentrer dans l'ordre, le réglage se fera automatiquement pour tous les sites iso.
Avatar de l’utilisateur
Babyl
Libellulien Junior
Libellulien Junior
 
Messages: 155
Inscription: 21 Juil 2011 13:16

Re: Caractères accentués remplacés par points d'interrogati

Messagepar Hapax » 14 Déc 2011 06:55

il arrive que Firefox "croit" lire de l'unicode et l'affiche comme tel...
Si la détection automatique est activée (universel),l'encodage original apparait et Firefox sait comment lire la page...
(voir le post de Falkra)
pour exemple cette adresse:
http://www.orange-wifi.com/spotfinder/index.php

Image

il s'avère que la page n'est pas encodée en Unicode (UTF-8)...
Image
Si vous pensez que la technologie peut résoudre vos problèmes de sécurité, alors vous n’avez rien compris aux problèmes ni à la technologie. ( Bruce Schneier )
Avatar de l’utilisateur
Hapax
Modérateur
Modérateur
 
Messages: 11564
Inscription: 16 Juil 2008 10:45

Re: Caractères accentués remplacés par points d'interrogati

Messagepar Babyl » 14 Déc 2011 10:29

Oui hapax, mais quand le navigateur ne trouve le bon encodage il y a souvent une raison comme sur cette page, le charset n'est pas indiqué dans la page et de plus certains caractères accentués sont codés d'autres pas (erreur de l'éditeur) ce qui ne facilite pas la détection.
Ce qui explique aussi que dans ta première image "café" a bien son accent mais "à l'étranger" ça ne passe pas.
Elle passe d'ailleurs en iso et en occidental ces 2 encodages acceptent les accents.
code source :

Image
Avatar de l’utilisateur
Babyl
Libellulien Junior
Libellulien Junior
 
Messages: 155
Inscription: 21 Juil 2011 13:16

Re: Caractères accentués remplacés par des <?>

Messagepar fuzzystone » 15 Déc 2011 01:05

Bonjour,

Merci pour vos efforts, mais je reste perplexe :

Voici le résultat pour clubic en occidental (iso-8859-1) :

Image

Uploaded with ImageShack.us

C'est donc encore pire car avec le réglage unicode le problème n'apparaît que dans les onglets, alors que là c'est le texte qui est massacré.



Par contre ça marche avec le site de upc-cablecom.ch où le problème des points d'interrogation remplaçant les acccents apparaît dans le texte en unicode (utf-8) :

Image

Uploaded with ImageShack.us

... alors que tout rentre daans l'ordre en occidental (iso-8859-1)

A noter encore que j'utilise habituellement Opera qui a une option sélection automatique pour l'encodage, mais elle ne fait pas son boulot.

Où est le problème? Je commence à avoir très mal à la tête...

Merci. Fuzzystone.
fuzzystone
Libellulien
Libellulien
 
Messages: 94
Inscription: 05 Jan 2007 15:22

Précédente

Retourner vers Internet

Qui est en ligne

Utilisateurs parcourant ce forum: Aucun utilisateur enregistré et 2 invités