Comptes d'utilisateurs (XP) et reconnaissance hardware

La section des versions NT, 2000, et XP de windows : informations, problèmes, questions, avis ou dépannages y trouveront leur place.

Modérateur: Modérateurs

Comptes d'utilisateurs (XP) et reconnaissance hardware

Messagepar asheenlevrai » 11 Fév 2011 21:13

Bonjour à tous,

J'ai recu un appareil (USB) comprenant une camera (firewire). L'appareil et la camera sont commandés par un software tournant sous windows XP, livré sur un PC installé.
Windows XP pro SP3 est à jour.
Le PC n'avait à l'origine qu'un compte utilisateur (administrateur) nommé "User".
Comme il y aura plusieurs utilisateurs différents pour cet appareil, j'ai voulu créer des comptes d'utilisateurs (limités).
J'ai crée le compte "Mr_A" (administrateur).
J'ai passé "User" en compte limité.
J'ai crée le compte "Mr_B" (limité).

Là je m’aperçois que "Mr_B" ne peut pas utiliser le programme pour commander l'appareil: la caméra n'est pas reconnue.
Je me suis dit que c'était un problème de "droits" car pour "MR_A" (administrateur) tout va bien.
J'ai fait plein de tests et voici les résultats:
- Tout compte (administrateur) pourra utiliser le programme correctement.
- Tout compte (limité) ne pourra pas utiliser le programme (camera non reconnue).
Il y a qqe exceptions:
1) le compte "User" peut utiliser le programme même si il est "limité" (je n'arrive pas à comprendre pourquoi?!?)
2) si je crée un compte "Mr_C" (administrateur) et que je le passe en limité, il pourra utiliser le programme jusqu'au prochain reboot (dès lors la camera ne sera plus reconnue).

Je suis un peu perdu.
Je ne peux pas créer uniquement des comptes administrateurs car les divers utilisateurs vont mettre la pagaille à coup sûr.

Est-ce que qqn aurait une idée de ce qui se passe?

merci d'avance pour votre aide.
-a-
Avatar de l’utilisateur
asheenlevrai
Super Libellulien
Super Libellulien
 
Messages: 1256
Inscription: 12 Juil 2005 07:26
Localisation: Geneve

Re: Comptes d'utilisateurs (XP) et reconnaissance hardware

Messagepar messan » 16 Fév 2011 08:40

:plaf: slt celui ki a des problème. comment tu vas, j'espers que mal. je vien de te lire avec attention et la seule chose que je trouve a ton problème est seulement qu'il est étrange. bon on fera avec c'est quand même l'informatique. tu installe des pilotes de périphérique qui ne fonctionne qu'en session administrateur(bizarre).

bon moi la question que je me pose est de savoir : ton Windows XP SP3, estce qu'il est bien portant? si oui grave :pouark: . même si il est en bonne sante essai de faire une correction de ton XP. après la correction ssi le problème persiste, installe les pilotes sur toutes les sessions avec ton droit d'administrateur. bon pour le moment c'est sa on éssai. d'ici l@ je pense que je trouverai quelque chose. :supers:
Avatar de l’utilisateur
messan
 
Messages: 2
Inscription: 15 Fév 2011 17:24

Re: Comptes d'utilisateurs (XP) et reconnaissance hardware

Messagepar asheenlevrai » 16 Fév 2011 09:28

messan a écrit::plaf: slt celui ki a des problème.


apparemment tu me connais bien ;-)


messan a écrit:je vien de te lire avec attention et la seule chose que je trouve a ton problème est seulement qu'il est étrange.


indeed...

messan a écrit:tu installe des pilotes de périphérique qui ne fonctionne qu'en session administrateur(bizarre).

En fait moi je n'ai installé aucun pilote, la machine est arrivée livrée et installé (1 seul utilisateur). Ce qui est étrange c'est que cet utilisateur "fonctionne" bien, même si son comptes est "limité" (non-administrateur).

messan a écrit: bon moi la question que je me pose est de savoir : ton Windows XP SP3, estce qu'il est bien portant? si oui grave :pouark: .


A priori oui :-s j'ai fait toutes les MAJ est aucun problème n'est signalé par windows, mais je ne suis pas allé plus loin...

messan a écrit: essai de faire une correction de ton XP


tu peux développer STP, je ne sais pas en quoi ca consiste...


messan a écrit: après la correction si le problème persiste, installe les pilotes sur toutes les sessions avec ton droit d'administrateur.


Et bien en fait je n'ai aucun pilote (machine fournie installée), même pas l'install du soft d'acquisition... (machine livrée installée). Je vais contacter l'éditeur si nécessaire.

merci pour ton aide.
à bientôt
-a-
Avatar de l’utilisateur
asheenlevrai
Super Libellulien
Super Libellulien
 
Messages: 1256
Inscription: 12 Juil 2005 07:26
Localisation: Geneve

Re: Comptes d'utilisateurs (XP) et reconnaissance hardware

Messagepar Falkra » 16 Fév 2011 09:56

Conclusion, si vous pouvez aider, les coups de main sont bienvenus, mais sinon, les messages bizarres, on a assez de l'ordinateur pour ça.
Avatar de l’utilisateur
Falkra
Admin libellules.ch
Admin libellules.ch
 
Messages: 25882
Inscription: 30 Jan 2005 13:44
Localisation: 127.0.0.1

Re: Comptes d'utilisateurs (XP) et reconnaissance hardware

Messagepar TopXm » 16 Fév 2011 14:52

Salut,

Eventuellement, lors de l'installation du Soft il t'a été demandé si tu souhaitais installer pour l'utilisateur en cours ou pour tous.

Si tu as choisis utilisateur en cours alors tout nouveau compte invité créé ultérieurement ne pourra utiliser le Soft.

Il faudrait voir à installer à nouveau le produit pour tous si bien entendu cette option a été proposée.

C'est quoi le nom du Soft ?
Image
Téléchargement gratuit Give Away Of the day
Avatar de l’utilisateur
TopXm
Libellulien Junior
Libellulien Junior
 
Messages: 421
Inscription: 22 Jan 2008 23:44

Re: Comptes d'utilisateurs (XP) et reconnaissance hardware

Messagepar asheenlevrai » 17 Fév 2011 06:03

Encore une fois, ce n'est pas moi qui ai installé le soft, mais le fournisseur lui même. Les autres utilisateurs peuvent utiliser le soft sans problème si ce n'est que la caméra n'est pas reconnue (et donc le soft ne sert pas à grand chose....)
Avatar de l’utilisateur
asheenlevrai
Super Libellulien
Super Libellulien
 
Messages: 1256
Inscription: 12 Juil 2005 07:26
Localisation: Geneve

Re: Comptes d'utilisateurs (XP) et reconnaissance hardware

Messagepar TopXm » 17 Fév 2011 11:46

Salut,

Je n'avais pas lu ce passage, je m'étais arrêté au 1er post, la réponse suivante ne me paraissant pas utile, erreur de ma part désolé.

Hum, j'ai quand même une autre idée ! (peut-être pas bonne mais c'est une idée)

Dans certains cas, les Cams ont besoin d'un programme au lancement pour fonctionner. Ce programme se lance via une clé run par exemple :

HKEY_USERS\S-1-5-18\Software\Microsoft\Windows\CurrentVersion\Run
HKEY_USERS\S-1-5-19\Software\Microsoft\Windows\CurrentVersion\Run
HKEY_USERS\S-1-5-20\Software\Microsoft\Windows\CurrentVersion\Run
HKEY_USERS\S-1-5-21-484763869-1078081533-1801674531-1003\Software\Microsoft\Windows\CurrentVersion\Run

Il faut interpréter S-1-5-**** comme un utilisateur distinct. Imaginons que le programme que nécessite le Cam ne se lance que pour l'utilisateur ****
seul lui pourra utiliser la Cam.

Ce serait peut-être intéressant de faire une recherche dans le registre. Si tu es partant je t'explique la méthode.
Image
Téléchargement gratuit Give Away Of the day
Avatar de l’utilisateur
TopXm
Libellulien Junior
Libellulien Junior
 
Messages: 421
Inscription: 22 Jan 2008 23:44

Re: Comptes d'utilisateurs (XP) et reconnaissance hardware

Messagepar asheenlevrai » 17 Fév 2011 12:04

je regarde avec regedit si je vois ces clés dans le registre... je te tiens au courant asap...
merci pour ton aide
-a-
Avatar de l’utilisateur
asheenlevrai
Super Libellulien
Super Libellulien
 
Messages: 1256
Inscription: 12 Juil 2005 07:26
Localisation: Geneve


Retourner vers Windows NT, 2000, XP

Qui est en ligne

Utilisateurs parcourant ce forum: Aucun utilisateur enregistré et 0 invités