Icone vierges dans le menu Démarrer

La section attend toutes les questions, impressions, avis ou astuces ou informations sur Windows Vista, Windows 7, Windows 8. Les problèmes aussi...

Modérateur: Modérateurs

Icone vierges dans le menu Démarrer

Messagepar Airwave » 20 Déc 2008 00:21

Hello a tous,

J'ai un léger souci avec mon Vista (finalement lol)

Depuis quelques jours, j'ai des icônes qui sont "vierges" dans le menu Démarrer...

Il semblerait que les EXE aient complétement perdu la boule... étrangement quand on va dans propriétés du raccourdi, on peut reseter l'icone mais ca ne change rien...

Je vous donne une léger apercu:

Image

Est-ce que qqn a une idée?
Avatar de l’utilisateur
Airwave
Super Libellulien
Super Libellulien
 
Messages: 1321
Inscription: 21 Juin 2003 16:31
Localisation: Geneve

Re: Icone vierges dans le menu Démarrer

Messagepar Falkra » 20 Déc 2008 02:00

Bonsoir, si tu penses à un problème lié au paramètre d'icône associé à l'extension .exe, tu peux le restaurer avec le fichier reg dans ce zip (UAC probablement à désactiver d'abord) :
http://www.winhelponline.com/fileasso/exefix_vista.zip

Au pire ça ne fera rien, puisque ce sont les paramètres par défaut.
Avatar de l’utilisateur
Falkra
Admin libellules.ch
Admin libellules.ch
 
Messages: 25882
Inscription: 30 Jan 2005 13:44
Localisation: 127.0.0.1

Re: Icone vierges dans le menu Démarrer

Messagepar Airwave » 21 Déc 2008 11:38

Meric pour ta réponse... mais ton lien est mort...

J'hésite a m'engager sur cette piste, puisque comme tu le vois certaines icones d'exe sont toujours la... (très peu d'ailleurs)
Avatar de l’utilisateur
Airwave
Super Libellulien
Super Libellulien
 
Messages: 1321
Inscription: 21 Juin 2003 16:31
Localisation: Geneve

Re: Icone vierges dans le menu Démarrer

Messagepar Falkra » 21 Déc 2008 11:51

Mince, le site était ok hier, et là c'est tout le site qui est injoignable.
Je n'ai pas le fichier en backup, donc il faudra attendre.

Sinon, ça ne risque pas grand chose, et tu peux toujours faire un backup des clés, en cas de besoin.
D'ailleurs on va aller y jeter un oeil. Il faudra peut-être désactiver l'UAC le temps de la manip (je ne pense pas, mais au cas où, autant prévenir).

  • Ouvre le bloc notes. Copie-colle dedans le contenu de la boite code qui suit :
Code: Tout sélectionner
@echo off
echo.
echo  -=Extractions de la BdR=-
echo.

set cle=HKEY_CLASSES_ROOT\exefile
echo %cle%
regedit /E c:\reggM1.txt "%cle%"
echo  ------------->>c:\reggM1.txt

set cle=HKEY_CLASSES_ROOT\.exe
echo %cle%
regedit /E c:\reggM2.txt "%cle%"
echo  ------------->>c:\reggM2.txt

copy c:\reggM?.txt c:\regfile.txt>nul
del c:\reggM?.txt
notepad c:\regfile.txt
del c:\regfile.txt

  • Sauvegarde cela sur le bureau en donnant comme nom lib.bat (pas d'extension texte donc).
  • Le fichier va être créé avec une icône d'engrenage, place-le sur le bureau, double clique dessus et poste le rapport qui va s'afficher.
Avatar de l’utilisateur
Falkra
Admin libellules.ch
Admin libellules.ch
 
Messages: 25882
Inscription: 30 Jan 2005 13:44
Localisation: 127.0.0.1

Re: Icone vierges dans le menu Démarrer

Messagepar gedeon1999 » 21 Déc 2008 11:55

Falkra a écrit:http://www.winhelponline.com/fileasso/exefix_vista.zip
Au pire ça ne fera rien, puisque ce sont les paramètres par défaut.
Bonjour

Si le lien n'est plus actif, tu peux voir ici
http://winvistaforums.com/windows-vista ... ation.html
Avatar de l’utilisateur
gedeon1999
Modérateur
Modérateur
 
Messages: 2629
Inscription: 28 Nov 2007 23:06

Re: Icone vierges dans le menu Démarrer

Messagepar Airwave » 21 Déc 2008 16:53

J'ai parcouru le forum dont vous m'avez donné le lien et effectivement ca concerne un problème similaire sauf que chez moi les exe fonctionnent très bien... Tous se lancent, mais ils n'ont pas d'icône...

Mais bon comme on ne peut rien refuser a Falkra...

Code: Tout sélectionner
Windows Registry Editor Version 5.00

[HKEY_CLASSES_ROOT\exefile]
@="Application"
"EditFlags"=hex:38,07,00,00
"FriendlyTypeName"=hex(2):40,00,25,00,53,00,79,00,73,00,74,00,65,00,6d,00,52,\
  00,6f,00,6f,00,74,00,25,00,5c,00,53,00,79,00,73,00,74,00,65,00,6d,00,33,00,\
  32,00,5c,00,73,00,68,00,65,00,6c,00,6c,00,33,00,32,00,2e,00,64,00,6c,00,6c,\
  00,2c,00,2d,00,31,00,30,00,31,00,35,00,36,00,00,00

[HKEY_CLASSES_ROOT\exefile\DefaultIcon]
@="%1"

[HKEY_CLASSES_ROOT\exefile\shell]

[HKEY_CLASSES_ROOT\exefile\shell\open]
"EditFlags"=hex:00,00,00,00

[HKEY_CLASSES_ROOT\exefile\shell\open\command]
@="\"%1\" %*"
"IsolatedCommand"="\"%1\" %*"

[HKEY_CLASSES_ROOT\exefile\shell\runas]

[HKEY_CLASSES_ROOT\exefile\shell\runas\command]
@="\"%1\" %*"
"IsolatedCommand"="\"%1\" %*"

[HKEY_CLASSES_ROOT\exefile\shellex]

[HKEY_CLASSES_ROOT\exefile\shellex\ContextMenuHandlers]

[HKEY_CLASSES_ROOT\exefile\shellex\DropHandler]
@="{86C86720-42A0-1069-A2E8-08002B30309D}"

[HKEY_CLASSES_ROOT\exefile\shellex\IconHandler]
@="{611AD258-4138-4348-A534-9856FA6BA398}"

[HKEY_CLASSES_ROOT\exefile\shellex\PropertySheetHandlers]

[HKEY_CLASSES_ROOT\exefile\shellex\PropertySheetHandlers\ShimLayer Property Page]
@="{513D916F-2A8E-4F51-AEAB-0CBC76FB1AF8}"

[HKEY_CLASSES_ROOT\exefile\shellex\PropertySheetHandlers\{B41DB860-8EE4-11D2-9906-E49FADC173CA}]
@=""

ⴠⴭⴭⴭⴭⴭⴭ਍Windows Registry Editor Version 5.00

[HKEY_CLASSES_ROOT\.exe]
@="exefile"
"Content Type"="application/x-msdownload"

[HKEY_CLASSES_ROOT\.exe\PersistentHandler]
@="{098f2470-bae0-11cd-b579-08002b30bfeb}"

ⴠⴭⴭⴭⴭⴭⴭ਍
Avatar de l’utilisateur
Airwave
Super Libellulien
Super Libellulien
 
Messages: 1321
Inscription: 21 Juin 2003 16:31
Localisation: Geneve

Re: Icone vierges dans le menu Démarrer

Messagepar Falkra » 21 Déc 2008 17:03

Le paramètre d'icône est ok dans le registre pour les .exe : rien d'anormal, il faut donc chercher ailleurs, par exemple pour les raccourcis.
(mais il y a des spéciaux, ça va se compliquer)

Mais bon comme on ne peut rien refuser a Falkra...
Lol, dans mon profil, ça marque Tyran (mais de source trolls). :ptdr:

Voilà un 2eme batch, si tu veux tester. :P

Code: Tout sélectionner
@echo off
echo.
echo  -=Extractions de la BdR=-
echo.

set cle=HKEY_CLASSES_ROOT\lnkfile
echo %cle%
regedit /E c:\reggM1.txt "%cle%"
echo  ------------->>c:\reggM1.txt

set cle=HKEY_CLASSES_ROOT\.lnk
echo %cle%
regedit /E c:\reggM2.txt "%cle%"
echo  ------------->>c:\reggM2.txt

copy c:\reggM?.txt c:\regfile.txt>nul
del c:\reggM?.txt
notepad c:\regfile.txt
del c:\regfile.txt
Avatar de l’utilisateur
Falkra
Admin libellules.ch
Admin libellules.ch
 
Messages: 25882
Inscription: 30 Jan 2005 13:44
Localisation: 127.0.0.1

Re: Icone vierges dans le menu Démarrer

Messagepar Airwave » 22 Déc 2008 20:02

Et voila, capuccino!

Code: Tout sélectionner
Windows Registry Editor Version 5.00

[HKEY_CLASSES_ROOT\lnkfile]
@="Shortcut"
"EditFlags"=dword:00000001
"FriendlyTypeName"="@shell32.dll,-4153"
"IsShortcut"=""
"NeverShowExt"=""

[HKEY_CLASSES_ROOT\lnkfile\CLSID]
@="{00021401-0000-0000-C000-000000000046}"

[HKEY_CLASSES_ROOT\lnkfile\shellex]

[HKEY_CLASSES_ROOT\lnkfile\shellex\ContextMenuHandlers]

[HKEY_CLASSES_ROOT\lnkfile\shellex\ContextMenuHandlers\OpenContainingFolderMenu]
@="{37ea3a21-7493-4208-a011-7f9ea79ce9f5}"

[HKEY_CLASSES_ROOT\lnkfile\shellex\ContextMenuHandlers\{00021401-0000-0000-C000-000000000046}]
@=""

[HKEY_CLASSES_ROOT\lnkfile\shellex\DropHandler]
@="{00021401-0000-0000-C000-000000000046}"

[HKEY_CLASSES_ROOT\lnkfile\shellex\IconHandler]
@="{00021401-0000-0000-C000-000000000046}"

[HKEY_CLASSES_ROOT\lnkfile\shellex\PropertySheetHandlers]

[HKEY_CLASSES_ROOT\lnkfile\shellex\PropertySheetHandlers\ShimLayer Property Page]
@="{513D916F-2A8E-4F51-AEAB-0CBC76FB1AF8}"

ⴠⴭⴭⴭⴭⴭⴭ਍Windows Registry Editor Version 5.00

[HKEY_CLASSES_ROOT\.lnk]
@="lnkfile"

[HKEY_CLASSES_ROOT\.lnk\ShellEx]

[HKEY_CLASSES_ROOT\.lnk\ShellEx\{000214EE-0000-0000-C000-000000000046}]
@="{00021401-0000-0000-C000-000000000046}"

[HKEY_CLASSES_ROOT\.lnk\ShellEx\{000214F9-0000-0000-C000-000000000046}]
@="{00021401-0000-0000-C000-000000000046}"

[HKEY_CLASSES_ROOT\.lnk\ShellEx\{00021500-0000-0000-C000-000000000046}]
@="{00021401-0000-0000-C000-000000000046}"

[HKEY_CLASSES_ROOT\.lnk\ShellEx\{BB2E617C-0920-11d1-9A0B-00C04FC2D6C1}]
@="{00021401-0000-0000-C000-000000000046}"

[HKEY_CLASSES_ROOT\.lnk\ShellNew]
"Handler"="{ceefea1b-3e29-4ef1-b34c-fec79c4f70af}"
"IconPath"=hex(2):25,00,53,00,79,00,73,00,74,00,65,00,6d,00,52,00,6f,00,6f,00,\
  74,00,25,00,5c,00,73,00,79,00,73,00,74,00,65,00,6d,00,33,00,32,00,5c,00,73,\
  00,68,00,65,00,6c,00,6c,00,33,00,32,00,2e,00,64,00,6c,00,6c,00,2c,00,2d,00,\
  31,00,36,00,37,00,36,00,39,00,00,00
"ItemName"="@shell32.dll,-30397"
"MenuText"="@shell32.dll,-30318"
"NullFile"=""

[HKEY_CLASSES_ROOT\.lnk\ShellNew\Config]
"DontRename"=""

ⴠⴭⴭⴭⴭⴭⴭ਍
Avatar de l’utilisateur
Airwave
Super Libellulien
Super Libellulien
 
Messages: 1321
Inscription: 21 Juin 2003 16:31
Localisation: Geneve

Re: Icone vierges dans le menu Démarrer

Messagepar Falkra » 22 Déc 2008 20:15

Oki, ce n'est pas une histoire d'associations dans la base de registre.

As-tu essayé de reconstruire le cache des icônes ?
Avatar de l’utilisateur
Falkra
Admin libellules.ch
Admin libellules.ch
 
Messages: 25882
Inscription: 30 Jan 2005 13:44
Localisation: 127.0.0.1

Re: Icone vierges dans le menu Démarrer

Messagepar Airwave » 27 Déc 2008 16:55

Yep, je l'ai fait avec la méthode effacement de IconCache.db puis reboot... Ca n'a rien changé...

C'est vraiment saoulant... Mais bon je peux survivre sans aussi...

En fait j'avais pensé a un truc plus compliqué genre le dossier sur le disque (ou plutot les dossiers vu qu'il semblerait qu'il prenne des éléments dans local et d'autres dans roaming) soit corrompu ou reconnu comme tels par le système...

Bref...

Mets l'riz qui s'masse! (celle-la est capillotractée...)
Avatar de l’utilisateur
Airwave
Super Libellulien
Super Libellulien
 
Messages: 1321
Inscription: 21 Juin 2003 16:31
Localisation: Geneve


Retourner vers Windows Vista, 7 et 8

Qui est en ligne

Utilisateurs parcourant ce forum: Aucun utilisateur enregistré et 0 invités