.NET Framework 3.5 SP1 problème installation / RESOLU

La section attend toutes les questions, impressions, avis ou astuces ou informations sur Windows Vista, Windows 7, Windows 8. Les problèmes aussi...

Modérateur: Modérateurs

Re: .NET Framework 3.5 SP1 problème installation

Messagepar dante77 » 06 Avr 2009 14:54

Ben vu que l'on s'absente en même temps, on pourra reprendre la semaine prochaine, si cela ne t'ennuies pas.



Alors le fichier secur32.dll, est en lecture et exécution.
Dante
Avatar de l’utilisateur
dante77
Super Libellulien
Super Libellulien
 
Messages: 1450
Inscription: 03 Mai 2006 01:01

Re: .NET Framework 3.5 SP1 problème installation

Messagepar maybe » 06 Avr 2009 15:43

OK, pas de souci. Si tu n'es pas encore parti, poster un deriner rapport mais cette fois tu laisses courir ProcessMonitor pendant 30 secondes après le blocage de l'installation du Framework.
« L’imprimerie a permis au peuple de lire, Internet va lui permettre d’écrire ». (Benjamin Bayart) http://www.framablog.org/index.php/post ... ture-seule
Avatar de l’utilisateur
maybe
Maître Libellulien
Maître Libellulien
 
Messages: 608
Inscription: 02 Déc 2008 10:04
Localisation: ailleurs

Re: .NET Framework 3.5 SP1 problème installation

Messagepar dante77 » 06 Avr 2009 16:36

Alors j'ai refait comme tu m'as dit et voici le lien, fichier plus gros du au 30 secondes chrono....Fast and Furious.... :xpdr:


http://www.mediafire.com/file/52tk5mfqt ... ework3.zip



Bonne lecture, et encore un grand merci pour ton aide....je pars ce soir vers 20h, mais pas de soucis, c'est pas trop urgent vu que je peux pas utiliser l'autre portable, mais c'est vraiment très sympa de ta part!

Car moi, là, j'y comprends rien de chez rien.... :crazy:

Sincèrement

Dante
Dante
Avatar de l’utilisateur
dante77
Super Libellulien
Super Libellulien
 
Messages: 1450
Inscription: 03 Mai 2006 01:01

Re: .NET Framework 3.5 SP1 problème installation

Messagepar maybe » 06 Avr 2009 17:09

Loupé pour celui-ci : je ne peux pas l'ouvrir.
« L’imprimerie a permis au peuple de lire, Internet va lui permettre d’écrire ». (Benjamin Bayart) http://www.framablog.org/index.php/post ... ture-seule
Avatar de l’utilisateur
maybe
Maître Libellulien
Maître Libellulien
 
Messages: 608
Inscription: 02 Déc 2008 10:04
Localisation: ailleurs

Re: .NET Framework 3.5 SP1 problème installation

Messagepar dante77 » 06 Avr 2009 17:21

Ben moi je sais même pas comment on ouvre un fichier PML.....

Je refais un PM sur l'autre portable, en espérant qu'il s'ouvrira.....
Dante
Avatar de l’utilisateur
dante77
Super Libellulien
Super Libellulien
 
Messages: 1450
Inscription: 03 Mai 2006 01:01

Re: .NET Framework 3.5 SP1 problème installation

Messagepar maybe » 06 Avr 2009 17:31

Je refais un PM sur l'autre portable, en espérant qu'il s'ouvrira.

Pas certaine de te suivre : il faut lancer le logiciel à partir du pc qui pose problème.
« L’imprimerie a permis au peuple de lire, Internet va lui permettre d’écrire ». (Benjamin Bayart) http://www.framablog.org/index.php/post ... ture-seule
Avatar de l’utilisateur
maybe
Maître Libellulien
Maître Libellulien
 
Messages: 608
Inscription: 02 Déc 2008 10:04
Localisation: ailleurs

Re: .NET Framework 3.5 SP1 problème installation

Messagepar dante77 » 06 Avr 2009 17:59

ben celui-ci est le portable sans problème, c'est le 2ème qui me pose problème, donc je jongle sur 2 pc, d'ou la lenteur....

j'ai donc refait un PM sur le pc qui coince, et voici le lien pour le nouveau rapport:

http://www.mediafire.com/file/1d5zycgi1 ... ework4.zip

plus petit cette fois le fichier, 14 Mo en zip

Je ne pourrai pas refaire un autre PM pour aujourd'hui, car je pars dans 2 heures....donc espérons que celui-ci soit bon...

Je te remercie sincèrement pour ta gentillesse et patience! :supers:

a+

Dante
Dante
Avatar de l’utilisateur
dante77
Super Libellulien
Super Libellulien
 
Messages: 1450
Inscription: 03 Mai 2006 01:01

Re: .NET Framework 3.5 SP1 problème installation

Messagepar maybe » 06 Avr 2009 18:03

ben celui-ci est le portable sans problème, c'est le 2ème qui me pose problème, donc je jongle sur 2 pc, d'ou la lenteur....

Si tu jongles pour transférer le fichier PML d'un pc à l'autre, c'est ok.

plus petit cette fois le fichier, 14 Mo en zip
Je ne pourrai pas refaire un autre PM pour aujourd'hui, car je pars dans 2 heures....donc espérons que celui-ci soit bon...

Pas d'urgence. 14 Mo, ça ne me paraît pas beaucoup : je télécharge et je regarde. Si ça ne va pas, je te le ferai savoir à ton retour. Bonne virée.
« L’imprimerie a permis au peuple de lire, Internet va lui permettre d’écrire ». (Benjamin Bayart) http://www.framablog.org/index.php/post ... ture-seule
Avatar de l’utilisateur
maybe
Maître Libellulien
Maître Libellulien
 
Messages: 608
Inscription: 02 Déc 2008 10:04
Localisation: ailleurs

Re: .NET Framework 3.5 SP1 problème installation

Messagepar dante77 » 07 Avr 2009 01:11

Bonjour,

j'ai pu me connecter à un hotspot et j'en profite encore pour te remercier!

Oui, je passe le fichier PML du pc malade à celui-ci.... :ptdr:

Merci pour la virée, il fait beau, on verra bien.....

à bientôt....je tenterai de me reconnecter.

A+

Dante
Dante
Avatar de l’utilisateur
dante77
Super Libellulien
Super Libellulien
 
Messages: 1450
Inscription: 03 Mai 2006 01:01

Re: .NET Framework 3.5 SP1 problème installation

Messagepar maybe » 07 Avr 2009 06:45

Ce sera à vérifier mais il te manque un paquet de clés dans le registre, qui appartiennent à la clé FeatureControl. HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Internet Explorer\Main\FeatureControl

Tout au moins on peut voir dans le rapport que l'installation les cherche mais ne les trouve pas. Je ne sais pas si ça n'est qu'une partie du problème.
« L’imprimerie a permis au peuple de lire, Internet va lui permettre d’écrire ». (Benjamin Bayart) http://www.framablog.org/index.php/post ... ture-seule
Avatar de l’utilisateur
maybe
Maître Libellulien
Maître Libellulien
 
Messages: 608
Inscription: 02 Déc 2008 10:04
Localisation: ailleurs

Re: .NET Framework 3.5 SP1 problème installation

Messagepar dante77 » 07 Avr 2009 10:42

Bonjour,

j'ai pu me reconnecter et ben c'est peut-être un début d'explication......au pauvre pc malade.... :supers:

En tout cas c'est hyper sympa de te pencher sur ce pavé de problèmes! :supers:

Encore un grand merci et une bonne journée

je tente de me connecter plus tard

a+
Dante
Avatar de l’utilisateur
dante77
Super Libellulien
Super Libellulien
 
Messages: 1450
Inscription: 03 Mai 2006 01:01

Re: .NET Framework 3.5 SP1 problème installation

Messagepar maybe » 07 Avr 2009 11:29

j'ai pu me reconnecter et ben c'est peut-être un début d'explication

Sûrement. Souvent un Framework qui ne s'installe pas est le signe d'une faille/instabilité du système.

Reste à savoir si ces clés manquantes ne sont qu'une partie émergée de l'iceberg ou pas. Pas impossible : un scannow qui bloque ne me plaît pas vraiment. Peut-être qu'une installation d'IE8 pourrait remettre tout d'équerre ? Pas sûre, mais dans tous les cas, ne le fais pas sans avoir sauvegardé tes données persos avant.
« L’imprimerie a permis au peuple de lire, Internet va lui permettre d’écrire ». (Benjamin Bayart) http://www.framablog.org/index.php/post ... ture-seule
Avatar de l’utilisateur
maybe
Maître Libellulien
Maître Libellulien
 
Messages: 608
Inscription: 02 Déc 2008 10:04
Localisation: ailleurs

Re: .NET Framework 3.5 SP1 problème installation

Messagepar dante77 » 07 Avr 2009 15:49

Re bonjour Maybe,

je ne fais rien sans ton avis....mais de toute manière jusqu'à dimanche je n'ai pas le pc malade avec moi, alors je risque pas de faire des bêtises.... :ptdr:

Par sauvegarder mes données, tu penses aux dossiers, profiles, etc? Ou une sauvegarde plus poussée?

IE8 peut avoir une si grande influence sur un système? Pourtant le pc tourne bien, il plante jamais, malgré ces fichiers corrompus.....étranges ces ordi.... :crazy:

Le portable que j'use en ce moment est aussi sous Vista, sans IE8 et il m'a prit NetFramew 3.5 sans roncher....

Je pense que ce n'est que la pointe de l'iceberg comme tu dis.....et encore merci pour ton aide :supers:

A+
Dante
Avatar de l’utilisateur
dante77
Super Libellulien
Super Libellulien
 
Messages: 1450
Inscription: 03 Mai 2006 01:01

Re: .NET Framework 3.5 SP1 problème installation

Messagepar maybe » 07 Avr 2009 20:00

je ne fais rien sans ton avis....mais de toute manière jusqu'à dimanche je n'ai pas le pc malade avec moi, alors je risque pas de faire des bêtises.... :ptdr:

C'est aussi une autre façon de traiter le problème. :mrgreen:

Par sauvegarder mes données, tu penses aux dossiers, profiles, etc? Ou une sauvegarde plus poussée?

Fichiers persos (photos, musique, etc).

IE8 peut avoir une si grande influence sur un système? Pourtant le pc tourne bien, il plante jamais, malgré ces fichiers corrompus.....étranges ces ordi.... :crazy:

Oui, c'est possible.
« L’imprimerie a permis au peuple de lire, Internet va lui permettre d’écrire ». (Benjamin Bayart) http://www.framablog.org/index.php/post ... ture-seule
Avatar de l’utilisateur
maybe
Maître Libellulien
Maître Libellulien
 
Messages: 608
Inscription: 02 Déc 2008 10:04
Localisation: ailleurs

Re: .NET Framework 3.5 SP1 problème installation

Messagepar dante77 » 08 Avr 2009 15:16

Salut Maybe,

oui, parfois il y a des moyens simples de traiter un problème....on jette le pc.... :xpdr:

Ok pour les fichiers persos...sur DD externe...vite fait....j'avais fait une image du pc, cela sauve aussi les fichiers ou juste le système? Quand tout est sur C ? Seul l'image est sur une autre partition.

Et ben, il est sympa le petit explorer si il peut causer ce genre de problème.....si on pouvait le gicler..... :ptdr:

A+

PS: merci encore et encore
Dante
Avatar de l’utilisateur
dante77
Super Libellulien
Super Libellulien
 
Messages: 1450
Inscription: 03 Mai 2006 01:01

Re: .NET Framework 3.5 SP1 problème installation

Messagepar maybe » 09 Avr 2009 22:10

Hello Dante,

j'avais fait une image du pc, cela sauve aussi les fichiers ou juste le système? Quand tout est sur C ?

Si tes fichiers persos sont sur C: ils seront aussi sauvegardés. Avant de jeter le pc par la fenêtre, voilà mes dernières cartouches.

1/ Vérification de la clé HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Internet Explorer\Main\FeatureControl

- Démarrer / Exécuter / taper regedit / OK
- naviguer jusqu'à cette clé HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Internet Explorer\Main\FeatureControl
- envoyer une capture d'écran des sous-clés de cette clé FeatureControl.

En fonction de cette capture, on continuera ou pas les solutions suivantes

2/ Outil de vérification

- télécharger l'outil NET Framework Setup Verification Tool : http://blogs.msdn.com/astebner/pages/8999004.aspx
- décompresser le fichier et double-clic sur l'exe (ne s'installe pas).
- cliquer sur Oui puis sur Yes
- dans le menu déroulant, rester sur la première entrée proposée
- cliquer sur Verify now
- quand la vérification est terminée, cliquer sur View Log
- un fichier va s'éditer automatiquement : menu Fichier / Enregistrer sous /
lui donner le nom du Framework qui a été vérifié : exemple Framework 2 SP2.txt

- reprendre la même procédure pour tous les Frameworks proposés dans le menu déroulant (Verify Now / View Log / sauvegarde du fichier-texte)
- quand tous les Frameworks ont été vérifiés, cliquer sur Exit

- créer un dossier dans lequel tu placeras tous les fichiers sauvegardés (autant de fichiers que de Frameworks détectés sur ton pc)
- le compresser et l'uploader ici par exemple : http://www.cijoint.fr/
- me donner le lien pour que je puisse le télécharger

Attendre les résultats avant de passer à l'étape suivante.

3/ SoftwareDistribution (méthode Crosoft)

Le rapport de ProcessMonitor indique aussi des erreurs concernant ce dossier : INVALID PARAMETER et NAME INVALID. Peut-être qu'en supprimant son contenu, ça débloquera tout.

1. Démarrer / Exécuter / taper services.msc / OK
2. Dans la fenêtre Services, cliquer avec le bouton droit sur Mises à jour automatiques, puis cliquer sur Arrêter.
3. Réduire la fenêtre des Services.
4. Aller dans C:\Windows\SoftwareDistribution
5. Sélectionner tout le contenu du dossier SoftwareDistribution et le copier dans un dossier que tu auras créé sur un support externe.
6. Réactiver la fenêtre des Services : clic droit sur Mises à jour automatiques / Démarrer
7. Arrêter l'ordinateur
8. Le redémarrer et exécuter Windows Update

Si le Framework ne veut toujours pas s'installer, quelqu'un d'autre aura peut-être de meilleures idées. A noter tout de même : si on force trop l'installation d'un Framework, cela peut bloquer le pc, et même aller jusqu'à une réinstallation. :mrgreen:
« L’imprimerie a permis au peuple de lire, Internet va lui permettre d’écrire ». (Benjamin Bayart) http://www.framablog.org/index.php/post ... ture-seule
Avatar de l’utilisateur
maybe
Maître Libellulien
Maître Libellulien
 
Messages: 608
Inscription: 02 Déc 2008 10:04
Localisation: ailleurs

Re: .NET Framework 3.5 SP1 problème installation

Messagepar mike55 » 10 Avr 2009 11:57

Bonjour Maybe et Dante77,
Je constate que ce problème persiste et pas de solution pour le moment ? Vider le contenu dans software distribution est une bonne idée surtout des updates windows du framework ( corruption possible ? il se peut ). Forcer une installation forcée comme tu dis, peut obliger une réinstallation. Ma question Maybe, si obligé de faire une réinstallation, pourquoi ne pas tenter ceci avant: supprimer le contenu dans distribution, désinstaller framework 3, installer le SP1 vista, il semblerait que le 3 est inclus dans le pack 1 et installer le 3.5.
mike55
Libellulien
Libellulien
 
Messages: 82
Inscription: 10 Jan 2009 15:10

Re: .NET Framework 3.5 SP1 problème installation

Messagepar maybe » 10 Avr 2009 15:15

Hello Mike,

désinstaller framework 3, installer le SP1 vista, il semblerait que le 3 est inclus dans le pack 1 et installer le 3.5.

Le Framework 3 est inclus dans Vista SP0. Je n'essaierais même pas de le désinstaller.
« L’imprimerie a permis au peuple de lire, Internet va lui permettre d’écrire ». (Benjamin Bayart) http://www.framablog.org/index.php/post ... ture-seule
Avatar de l’utilisateur
maybe
Maître Libellulien
Maître Libellulien
 
Messages: 608
Inscription: 02 Déc 2008 10:04
Localisation: ailleurs

Re: .NET Framework 3.5 SP1 problème installation

Messagepar mike55 » 10 Avr 2009 15:42

Bonjour Maybe,
J'ai toujours pensé que le framework 3 SP1 devait être installé avant le 3.5 et qui semble être inclus dans SP1 pour vista, aurait pu résoudre, mais enfin..
Merci encore pour l'info.
mike55
Libellulien
Libellulien
 
Messages: 82
Inscription: 10 Jan 2009 15:10

Re: .NET Framework 3.5 SP1 problème installation

Messagepar dante77 » 11 Avr 2009 14:48

Salut Maybe et Mike55,

Merci Maybe, je vois que cela se corse, ou y'a pas de difficulté y'a pas de plaisir il paraît.... :mrgreen:

Ouais, ben dès que je suis rentré et j'ai dans les mains le pc malade, avant qu'il vole par la fenêtre, on va tenter tout cela.
Sur un malentendu, cela peut fonctionner.... :supers:

En tout cas Maybe, je te remercie encore et encore pour la peine que tu te donnes, c'est vraiment sympa!

C'est pas des machines qui vont nous commander, non mais... :ptdr: Terminator est pas dans le coin encore....

J'en profite pour te souhaiter une Joyeuse Pâques au passage...c'est toujours des jours fériés de pris.... :xpdr:

A+

Sincèrement

Dante
Dante
Avatar de l’utilisateur
dante77
Super Libellulien
Super Libellulien
 
Messages: 1450
Inscription: 03 Mai 2006 01:01

PrécédenteSuivante

Retourner vers Windows Vista, 7 et 8

Qui est en ligne

Utilisateurs parcourant ce forum: Aucun utilisateur enregistré et 0 invités