Pas possible d'effacer des fichiers

Questions, trucs, astuces, coup de pouce sur le vaste thème du réseau...
Installation, configuration, partage, WiFi, CPL, dépannage, les libelluliens sont prêts à vous aider.

Modérateur: Modérateurs

Pas possible d'effacer des fichiers

Messagepar kini12 » 28 Mar 2004 02:51

Bonjour, je ne sais pas si je dois poster ce sujet ici ou dans la rubrique hardware, mais je me lance.
Depuis peu, il m'est impossible d'effacer des fichiers (vidéos, mp3, etc) stockés sur un disque que je partage sous edonkey. Le système m'indique que le fichier que je tente de supprimer est utilisé par un autre utilisateur, d'ou l'imposibilité d'effacer. Bien entendu, j'ai essayé de supprimer le fichier sans être connecté à internet et edonkey, j'obtiens le même message.
J'en ai parlé autour de moi et j'ai trouvé 2 autres personnes qui ont le même problème.

Quelqu'un sait quoi faire à part formater le disque?
Ce que l'on fait dans cette vie résonne pour l'éternité. (R.Crowe "Gladiator")
kini12
Libellulien Junior
Libellulien Junior
 
Messages: 317
Inscription: 07 Mar 2004 20:22

Messagepar phedre » 28 Mar 2004 09:43

Salut,

Essaie de démarrer windows en mode invite de commandes (dos) et de supprimer les fichiers avec la commande DEL. ou éventuellement essaie en mode sans échec
Avatar de l’utilisateur
phedre
Libellulien Junior
Libellulien Junior
 
Messages: 160
Inscription: 21 Fév 2004 22:16
Localisation: Neuchâtel

Pas possible d'effacer des fichiers

Messagepar ernie » 28 Mar 2004 10:04

C'est un problème apparemment assez courant. Je l'ai vu mentionné dans pas mal de forums. J'ai pas vu d'explication convaincante de la cause. Une des parades est de créer un fichier bidon dans un autre répertoire avec le même nom puis de l'utiliser pour remplacer le fichier qui ne s'efface pas. De fait, ton fichier ineffaçable est supprimé. Après remplacement, tu devrais pouvoir effacer le fichier bidon.
Avatar de l’utilisateur
ernie
Libellulien Junior
Libellulien Junior
 
Messages: 113
Inscription: 28 Mar 2004 09:59
Localisation: Là, juste là...

Messagepar Jesty » 28 Mar 2004 14:38

Salut,
J'avais le même problème, c'est-à-dire que je pouvais pas effacer certains fichiers vidéos, car le message d'erreur disait que le fichier était encore en utilisation.

Puis, quelques temps après, j'ai eu l'explorer.exe qui partait en c... Dans le gestionnaire de taches, explorer.exe prenait 100 % du processeur lorsque j'étais avec l'explorateur dans mes dossiers contenant des médias (souvent obtenus avec un P2P).
Je comprenais pas, j'ai même changé de shell, mais ça n'a rien changé, l'UC était toujours saturé.

En fait, il y a certains fichiers médias qui sont corrompus. Et l'explorateur va rechercher les informations lui-même pour y mettre à jour (ce qui peut prendre beaucoup de ressource comme dans mon cas).
Il est possible de désactiver cette recherche de l'explorateur en allant de le regedit à l'arborescence (j'ai XPpro) :

HKEY_CLASSES_ROOT\SystemFileAssociations\.avi\shellex\PropertyHandler
puis supprimer la valeur "Défaut" qui donne "{87D62D94-71B3-4b9a-9489-5F6850DC73E}". C'est possible de sauvegarder auparavant en faisant "Fichier/Exporter", en le renommant, par exemple, handler_avi.reg.

Pour ma part, depuis cette manip., je n'ai plus eu de problème pour effacer des fichiers (et le processeur d'explorer.exe s'est calmé également).

Bonne chance.
Avatar de l’utilisateur
Jesty
Libellulien
Libellulien
 
Messages: 56
Inscription: 28 Mar 2004 14:13

Messagepar bororo » 28 Mar 2004 20:19

salut
On peut aussi se servir de l'explorateur de Nero pour effacer le fichier
Il ne le refuse pas.
Avatar de l’utilisateur
bororo
Modérateur
Modérateur
 
Messages: 2124
Inscription: 13 Déc 2003 20:33
Localisation: Bordeaux

Messagepar permidion » 28 Mar 2004 21:38

Avatar de l’utilisateur
permidion
Maître Libellulien
Maître Libellulien
 
Messages: 807
Inscription: 09 Mar 2004 18:47

Messagepar kini12 » 04 Avr 2004 12:08

Merci pour votre aide à tous! J'ai finalement réussi à éradiquer ces F*"" fichiers!

A+
Ce que l'on fait dans cette vie résonne pour l'éternité. (R.Crowe "Gladiator")
kini12
Libellulien Junior
Libellulien Junior
 
Messages: 317
Inscription: 07 Mar 2004 20:22

Messagepar bororo » 11 Avr 2004 23:52

Salut
J'ai trouvé ceci:

- Beaucoup d'entre vous ont été confronté au problème de suppression ou pour renommer des fichiers AVI.
Cela provient d'un mauvais fonctionnement de l'extension de l'interface d'extraction des propriétés des fichiers multimédia ("shmedia.dll") propre à XP.
Lancer l'EDITEUR de REGISTRE.

- HKEY_LOCAL_MACHINE
SOFTWARE
Classes
CLSID
{87D62D94-71B3-4b9a-9489-5FE6850DC73E}
InProcServer32

- Supprimer cette clé.
Avatar de l’utilisateur
bororo
Modérateur
Modérateur
 
Messages: 2124
Inscription: 13 Déc 2003 20:33
Localisation: Bordeaux


Retourner vers Réseaux

Qui est en ligne

Utilisateurs parcourant ce forum: Aucun utilisateur enregistré et 0 invités