PE Builder, Bart PE et Process Monitor

Posez ici toutes les questions concernant un ou plusieurs logiciels, payants ou gratuits. Pour les demandes spécifiques aux systèmes d'exploitation, passez plutôt par les sections dédiées.

Modérateur: Modérateurs

PE Builder, Bart PE et Process Monitor

Messagepar avecesar » 12 Jan 2009 10:51

Bonjour à tous de la part d'un nouvel inscrit qui apprécie depuis plusieurs mois ce forum.

Malgré de nombreuses recherches en fr et en sur Internet, je bloque sur le problème ci-dessous.

J'ai réalisé un CD BartPE avec PE Builder 3.1.10a et XP SP2, qui fonctionne bien avec plusieurs logiciels.

J'ai voulu ajouter Process Explorer de SysInternals (dernière version),qui me renvoie des erreurs, quand je le lance deuis le CD BartPE:

- soit "Process Monitor requires Administrators group membership", si je lance depuis X:\Programs\ProcMon
- soit "Unable to load Process Monitor device driver", si je le lance depuis la RAM (après l'avoir avoir copié dans b:\procmon).

Son fichier .inf est tout simple:
[Version]
Signature= "$Windows NT$"

[PEBuilder]
Name="ProcMon"
Enable=1

[WinntDirectories]
a="Programs\procmon",2

[SourceDisksFiles]
files\*.*=a,,1

[Append]
nu2menu.xml, procmon_nu2menu.xml

D'autre part, il semblerait manquer dans le chainage des dll's de procmon.exe plusieurs dll's: Advpack, Cdfview, Efsadu...etc (vues avec l'utilitaire Dependency Walker).

J'ai essayé de les mettre dans le répertoire de procmon (et elle apparaissent bien à cet emplacement sur le CD), mais le problème est inchangé.

Peut-être faudrait-il qu'elles apparaissent dans le I386\system32 du CD, mais à ce moment-là, comment les y intégrer?

Merci beaucoup tout d'abord pour m'avoir lu jusqu'au bout icon_wink.gif et ensuite pour vos éventuelles suggestions.
avecesar
 
Messages: 3
Inscription: 12 Jan 2009 10:43

Retourner vers Software - Logiciels

Qui est en ligne

Utilisateurs parcourant ce forum: Aucun utilisateur enregistré et 1 invité