petite croix rouge

La section des versions NT, 2000, et XP de windows : informations, problèmes, questions, avis ou dépannages y trouveront leur place.

Modérateur: Modérateurs

petite croix rouge

Messagepar mitchdefr » 02 Sep 2006 08:13

bonjour à tous,


je viens de visité un site pour automobile,on peut regarder des images,moi je peut pas pourquoi.
il y a une petite croix rouge devant le mot image,j'ai cliqué dessus ,rien ne ce passe,pouvez vous me dire.
merci
Avatar de l’utilisateur
mitchdefr
Libellulien
Libellulien
 
Messages: 74
Inscription: 13 Aoû 2006 10:25

Messagepar Jason » 02 Sep 2006 09:20

salut !

si tu peux voir les images sur les autres sites, cela vient sans doute du site lui-même, mais il faudrait que tu nous donnes son adresse pour vérifier.

@+
pour trouver sans chercher,il faut avoir longtemps cherché sans trouver
Avatar de l’utilisateur
Jason
Libellulien Junior
Libellulien Junior
 
Messages: 327
Inscription: 01 Sep 2004 22:38
Localisation: Toulouse

bonjour jason

Messagepar mitchdefr » 02 Sep 2006 09:26

je te met le site en question,dit moi si toi tu vois des images

http://www.yaronet.com/posts.php?s=34871

merci
Avatar de l’utilisateur
mitchdefr
Libellulien
Libellulien
 
Messages: 74
Inscription: 13 Aoû 2006 10:25

Messagepar Jason » 02 Sep 2006 13:18

salut !

les images ne sont pas disponibles sur le site, c'est pour cela que ton navigateur affiche de petites croix rouges. Elles ont été soit supprimées, soit déplacées dans une autre arborescence sans changer le chemin d'accès dans le code html.

@+
pour trouver sans chercher,il faut avoir longtemps cherché sans trouver
Avatar de l’utilisateur
Jason
Libellulien Junior
Libellulien Junior
 
Messages: 327
Inscription: 01 Sep 2004 22:38
Localisation: Toulouse

Messagepar deltac1 » 02 Sep 2006 15:17

En fait c'est presque ça : moi je n'ai pas de croix mais la mention IMG.

Déjà voir si la création au format HTM est compatible avec les principaux navigateurs (j'ai testé sous Firefox sans aller plus loin......)

Donc il faut peut-être refaire la page avec un mode compatibilité avec d'autres navigateurs

Lorsqu'on a les croix, c'est en principe que le lien n'est pas bon ou que les images ont été enlevées du serveur. Mais IMG, à mon avis, c'est un conflit de navigateurs.

Ouilllouillouille !!!!!

:roll:
deltac1
 

Messagepar Falkra » 02 Sep 2006 15:21

C'est exactement ça : lien mort (site perso sur page voila.fr). IE affiche la croix rouge, et le texte alternatif (IMG), et FF se contente d'afficher le texte alternatif, sans croix rouge.
Avatar de l’utilisateur
Falkra
Admin libellules.ch
Admin libellules.ch
 
Messages: 25882
Inscription: 30 Jan 2005 13:44
Localisation: 127.0.0.1

Messagepar deltac1 » 02 Sep 2006 15:37

Donc ce n'est pas mon navigateur qui débloque !!!!

En fait, c'est dû au logiciel de création de page HTM qui est en incompatipilité.

FrontPage 2003, malgré ces bug, résume quand même bien le boulot (il se foût pas mal du langage html) mais voilà ! Il fait partie intégrante d'Office et Office n'est pas un gratuiciel !

:cry:
deltac1
 

Messagepar Falkra » 02 Sep 2006 16:04

En fait, dans l'exemple que nous avons - un forum - il s'agit de php, pas forcément développé avec frontpage, c'est donc un problème de rendu par le navigateur, en cas d'image dont le lien est erronné, IE affiche la croix rouge dans un rectangle blanc avec l'alttext, firefox se contente de l'alttext ici (opera aussi), au mieux, d'un rond rouge (quand image bloquée). Que frontpage ne soit pas une merveille côté standards, tout à fait d'accord.
Avatar de l’utilisateur
Falkra
Admin libellules.ch
Admin libellules.ch
 
Messages: 25882
Inscription: 30 Jan 2005 13:44
Localisation: 127.0.0.1

Messagepar deltac1 » 02 Sep 2006 17:16

Pas trop d'accord Falkra :

J'ai insisté sur le fait que FrontPage était issu du pur et dur MS mais il faut bien avouer qu'il sait créer des pages sous n'importe quel navigateur ceci sans forcement connaître le langage HTML.Il reconnait presque tous les navigateurs en ayant crée des pages à son instar. Bien sur, quelquefois, les textes ne clignotent pas ou ne changent pas de couleur selon certains navigateurs mais c'est quand même mieux que des IMG.

Je conseille à notre ami (e) de changer de programme de création HTM.

:wink:
deltac1
 

Messagepar Falkra » 02 Sep 2006 17:28

Je crois qu'on s'est mal compris. :) Précisons.

Oui, frontpage, c'est exactement ça, MS 100%, html, etc. Entièrement d'accord. Et il génère du code html 100% optimisé IE (normal). :lol:

Le site dont mitchdefr donne l'adresse (forum yaronet) n'est pas en html à proprement parler : c'est un forum, écrit en php. Le php (codé avec je ne sais quel logiciel, y compris le notepad) est exécuté par le serveur, qui génère de l'html que le navigateur interpête et rend graphiquement à l'écran.
Ici frontpage n'intervient pas, et aucun forum n'a de page html en soi (xyz.htm). Un forum est une base de données, dont l'interface est en php. Les pages de l'interface sont générées dynamiquement, rendues en html. (view.php?id=xyz)

Le rendu change selon les navigateurs (+/- de souplesse en interpétant le code html, ou l'html généré par php). Quand une image, déclarée dans une page, est manquante, IE rend cela graphiquement avec une croix rouge, FF non (choix de mozilla), il affiche le texte alternatif, la différence dans ce cas précis tient au navigateur, non au site ou à sa programmation ici, car c'est un forum.

Frontpage se débrouille bien pour cela, en html pur, et tu as raison de le souligner.
Avatar de l’utilisateur
Falkra
Admin libellules.ch
Admin libellules.ch
 
Messages: 25882
Inscription: 30 Jan 2005 13:44
Localisation: 127.0.0.1

Messagepar deltac1 » 02 Sep 2006 18:07

Mais ce n'était pas une raison pour se mettre dans une colère pareille !!!

8) :lol: :lol: :lol:
deltac1
 

Messagepar deltac1 » 02 Sep 2006 18:17

Je crois (et j'en suis sur) que la question, en début de topic, faisait allusion à un site perso. Si c'est mal fait on ne peut rien y faire !!!! :wink:
deltac1
 

Messagepar Falkra » 02 Sep 2006 19:27

deltac1 a écrit:Mais ce n'était pas une raison pour se mettre dans une colère pareille !!!

8) :lol: :lol: :lol:
Mais aucun problème (d'où les smileys souriants dans mon post). :-D :-D :-D
Avatar de l’utilisateur
Falkra
Admin libellules.ch
Admin libellules.ch
 
Messages: 25882
Inscription: 30 Jan 2005 13:44
Localisation: 127.0.0.1


Retourner vers Windows NT, 2000, XP

Qui est en ligne

Utilisateurs parcourant ce forum: Aucun utilisateur enregistré et 0 invités