[RESOLU] Le service Stockage amovible ne démarre pas

La section des versions NT, 2000, et XP de windows : informations, problèmes, questions, avis ou dépannages y trouveront leur place.

Modérateur: Modérateurs

Re: Problème avec l'outil gestion de l'ordinateur

Messagepar zardoz35 » 22 Juin 2009 10:02

Merci.
J'ai déjà regshot. Je suis au travail donc je fais ça en début de soirée.
zardoz35
Libellulien Junior
Libellulien Junior
 
Messages: 109
Inscription: 13 Oct 2008 18:18

Re: Problème avec l'outil gestion de l'ordinateur

Messagepar zardoz35 » 22 Juin 2009 18:25

Rapport de regshot en version 2.0.1.66 :
Par services.msc :
Clés effacées (0) pour le cliché A

Clés ajoutées (0) pour le cliché B

valeurs effacées (0) pour le cliché A

Valeurs ajoutées (0) pour le cliché B

valeurs modifiées (2) pour le cliché A
[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Cryptography\RNG]
"Seed"=hex:38,95,59,be,6c,da,3e,3b,60,ff,a5,8a,3f,49,4c,e7,f3,db,85,79,24,ee,\
5a,0e,a0,fb,3f,e3,89,8c,e5,4a,ba,e4,da,d6,85,eb,86,90,2f,48,c1,61,76,5f,60,\
48,ea,9e,9e,36,25,54,8d,f5,a5,89,11,ce,95,08,ff,ba,e0,71,f6,31,06,d3,d5,51,\
54,a4,80,90,16,04,9e,1d
"Seed"=hex:45,25,9a,e9,b8,25,a2,91,af,ba,8d,dc,35,53,19,00,17,a0,00,52,da,1b,\
51,ab,07,bc,67,6e,c3,ca,ed,f5,06,e3,4d,d2,95,54,78,ee,ca,c5,a1,b9,49,bd,be,\
5f,fd,bb,57,ca,70,37,4e,a9,0f,03,e3,5b,cb,26,dd,51,02,19,38,b5,aa,40,d3,65,\
a7,9d,c1,b2,1c,f8,f9,68
[HKEY_CURRENT_USER\SessionInformation]
"ProgramCount"=dword:00000003
"ProgramCount"=dword:00000004


Par poste de travail, gérer, stockage amovible :
Clés effacées (0) pour le cliché A

Clés ajoutées (0) pour le cliché B

valeurs effacées (0) pour le cliché A

Valeurs ajoutées (0) pour le cliché B

valeurs modifiées (1) pour le cliché A
[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Cryptography\RNG]
"Seed"=hex:49,8a,9c,48,48,26,7c,fb,19,36,6a,8c,50,d7,04,d0,1a,14,5a,9b,ff,e9,\
c4,cd,93,74,82,e5,4d,7d,a8,cd,c9,6a,d2,71,c2,e7,61,f7,b6,36,d9,45,80,98,e5,\
0d,30,d3,b1,dc,63,e0,02,77,5f,61,da,45,9b,50,21,be,57,dc,c5,31,2e,51,0e,55,\
08,8a,a1,6a,17,6f,e5,7e
"Seed"=hex:67,15,43,dd,eb,c3,d0,3e,d3,5f,34,1c,c1,42,3a,37,86,69,55,b3,83,43,\
17,49,00,24,7a,32,c5,11,5d,c3,ed,fa,af,4c,af,4b,26,f5,bc,04,89,3a,8d,7a,1c,\
ef,d2,47,d9,3e,99,5c,ea,1a,0a,60,a4,b1,93,50,e5,ba,6d,6a,5c,97,96,9b,df,ab,\
0e,26,5d,dd,ba,99,a4,20
zardoz35
Libellulien Junior
Libellulien Junior
 
Messages: 109
Inscription: 13 Oct 2008 18:18

Re: Problème avec l'outil gestion de l'ordinateur

Messagepar maybe » 22 Juin 2009 19:26

Le bug porte sur la première clé pour laquelle je t'avais d'éditer un fichier-texte.
Soit c'est un problème de droits, et ça peut se résoudre. Soit quelque chose bloque l'inscription dans cette clé du registre et là, je ne sais pas pourquoi.

- Démarrer / Exécuter / taper regedit / OK
- naviguer jusqu'à cette clé :

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\NtmsSvc\Config\Standalone

- clic droit / Autorisations
- fenêtre suivante : cliquer sur Paramètres avancés
- fenêtre suivante : une capture d'écran
- cliquer ensuite sur l'onglet Propriétaire : envoyer encore une capture d'écran
- sur cette même fenêtre, cliquer sur Annuler.
« L’imprimerie a permis au peuple de lire, Internet va lui permettre d’écrire ». (Benjamin Bayart) http://www.framablog.org/index.php/post ... ture-seule
Avatar de l’utilisateur
maybe
Maître Libellulien
Maître Libellulien
 
Messages: 608
Inscription: 02 Déc 2008 10:04
Localisation: ailleurs

Re: Problème avec l'outil gestion de l'ordinateur

Messagepar zardoz35 » 22 Juin 2009 20:08

zardoz35
Libellulien Junior
Libellulien Junior
 
Messages: 109
Inscription: 13 Oct 2008 18:18

Re: Problème avec l'outil gestion de l'ordinateur

Messagepar maybe » 22 Juin 2009 20:16

Rien à redire.

Ton pare-feu ? Firewall Softperfect : aucune restriction que tu aurais pu ajouter involontairement ?
« L’imprimerie a permis au peuple de lire, Internet va lui permettre d’écrire ». (Benjamin Bayart) http://www.framablog.org/index.php/post ... ture-seule
Avatar de l’utilisateur
maybe
Maître Libellulien
Maître Libellulien
 
Messages: 608
Inscription: 02 Déc 2008 10:04
Localisation: ailleurs

Re: Problème avec l'outil gestion de l'ordinateur

Messagepar zardoz35 » 22 Juin 2009 20:40

En arrêtant le pare feu softperfect c'est pareil.

Au fait, à quoi sert ce service alors que mes périphs usb (souris, disques, clés) fonctionnent correctement ?
Ma question initiale portait sur poste de travail/gérer/stockage amovible qui plante. Mais est-ce bien utile cette fonction ? Ça m'ennuie juste que tout ne fonctionne pas correctement.

Je peux recharger des images disques plus anciennes pour voir de quand ça date (1 ghost tous les 15 jours depuis 2 ans et demi).

Je te remercie de ton aide maybe mais je crains que l'on ne trouve pas la solution.
zardoz35
Libellulien Junior
Libellulien Junior
 
Messages: 109
Inscription: 13 Oct 2008 18:18

Re: Problème avec l'outil gestion de l'ordinateur

Messagepar maybe » 22 Juin 2009 21:03

Au fait, à quoi sert ce service alors que mes périphs usb (souris, disques, clés) fonctionnent correctement ?

Stockage amovible (Removable Storage)
Lancé par : svchost.exe
Description : Gère les médias amovibles, les lecteurs et autres. (ZIP, JAZ, bandes, etc). Ce service ne gère pas les périphériques USB (donc pas les clefs USB).
Le média est le support pour la mémoire, il a besoin d'un lecteur et il s'éjecte (d'où le "amovible"). La clef usb n'est donc pas un média. La cartouche Zip l'est.


les-services-windows-2000-xp-optimisations-t16542.html

Je peux recharger des images disques plus anciennes pour voir de quand ça date (1 ghost tous les 15 jours depuis 2 ans et demi).

Si tu penses que l'une de tes images-disque ne contient pas cette erreur, pourquoi pas même si ça n'expliquera pas d'où vient ce problème. En tous cas, ça n'est pas un conflit matériel. Le service démarre donc le bug n'est pas non plus le service lui-même : je pense que c'est l'intervention d'une fonction tierce / logiciel tiers qui met le bazar. Par exemple, tu as arrêté SuperCopier et pourtant dans le dernier rapport, il apparaît encore. :mrgreen:

mais je crains que l'on ne trouve pas la solution.

Je crois que j'ai fait le tour des pistes que j'avais. Mais il y a forcément une explication. Quelqu'un d'autre aura peut-être la bonne idée ?
« L’imprimerie a permis au peuple de lire, Internet va lui permettre d’écrire ». (Benjamin Bayart) http://www.framablog.org/index.php/post ... ture-seule
Avatar de l’utilisateur
maybe
Maître Libellulien
Maître Libellulien
 
Messages: 608
Inscription: 02 Déc 2008 10:04
Localisation: ailleurs

Re: Problème avec l'outil gestion de l'ordinateur

Messagepar maybe » 23 Juin 2009 07:15

http://www.lascon.co.uk/os00906.htm

  • Scroll to the 'Removable Storage' service in the 'Services' window.
  • Change the startup type for Removable Storage service to 'Disabled' the 'Stop' it.
  • Browse to \systemroot\system32\ntmsdata\, and then rename all files in that folder to *.OLD. You could just delete the RSM database files, but my preference is to keep the old ones 'just in case'.

  • Use Registry Editor to view the following registry key: (edit the registry with care and be aware that you can corrupt it by changing it and that could require a complete re-install of the Windows operating system) HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\NTMS
  • If the ImportDatabase REG_DWORD exists, change the value of the ImportDatabase REG_DWORD from 0 to 0x1.
    If it does not exist, add it with a value of 0x1: value name: ImportDatabase data type: REG_DWORD String: 1
    *]Change the Removable Storage service startup type to Automatic then start it. This should import the database from the export folder, build a new index file, and be consistent from when the last %Systemroot% backup was performed.

  • Change the Removable Storage service startup type to Automatic then start it. This will create a new database.
  • Restore the RSM database with your third party product

Probablement plus simple de restaurer une image-disque.
« L’imprimerie a permis au peuple de lire, Internet va lui permettre d’écrire ». (Benjamin Bayart) http://www.framablog.org/index.php/post ... ture-seule
Avatar de l’utilisateur
maybe
Maître Libellulien
Maître Libellulien
 
Messages: 608
Inscription: 02 Déc 2008 10:04
Localisation: ailleurs

Re: Problème avec l'outil gestion de l'ordinateur

Messagepar zardoz35 » 24 Juin 2009 18:47

Ça marche !!!!

J'ai appliqué à la lettre ce que tu as recopié :
* 'Services.msc' ---> stockage amovible
* Change the startup type for Removable Storage service to 'Disabled'
* c:\windows\system32\ntmsdata\ ------> j'ai effacé tous les fichiers (je les ai d'abord déplacés ailleurs)
* dans HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\NTMS
* j'ai créé ImportDatabase REG_DWORD , avec la valeur 0X01
* Change stockage amovible type to Automatic then start it. This will create a new database.

Maintenant quand je vais dans poste de travail/gérer ça fonctionne également.

Merci beaucoup maybe, tu es un champion

Ce soir je fais un ghost de mon système
zardoz35
Libellulien Junior
Libellulien Junior
 
Messages: 109
Inscription: 13 Oct 2008 18:18

Re: [ RESOLU ] Problème avec l'outil gestion de l'ordinateur

Messagepar maybe » 24 Juin 2009 18:59

Bien joué ! D'autant plus que je n'avais pas le temps de traduire quand j'ai posté mon message. En tous cas bravo pour ta ténacité, je t'ai tout de même bien fait tourner en rond. :mrgreen:
« L’imprimerie a permis au peuple de lire, Internet va lui permettre d’écrire ». (Benjamin Bayart) http://www.framablog.org/index.php/post ... ture-seule
Avatar de l’utilisateur
maybe
Maître Libellulien
Maître Libellulien
 
Messages: 608
Inscription: 02 Déc 2008 10:04
Localisation: ailleurs

Re: [ RESOLU ] Problème avec l'outil gestion de l'ordinateur

Messagepar zardoz35 » 24 Juin 2009 19:09

Le principal c'est le résultat (bon, j'ai du recharger au moins une image disque pour annuler de façon sure des modifications que je ne maitrisais pas).

En tout cas, au niveau ténacité, je vois que je n'ai rien à t'envier 8)
zardoz35
Libellulien Junior
Libellulien Junior
 
Messages: 109
Inscription: 13 Oct 2008 18:18

Re: [ RESOLU ] Problème avec l'outil gestion de l'ordinateur

Messagepar maybe » 24 Juin 2009 20:56

:wink: Si tu repasses dans le coin, ce serait bien d'éditer ton premier post pour modifier le titre du sujet (ex : le service Stockage amovible ne démarre pas). Merci et bonne continuation !
« L’imprimerie a permis au peuple de lire, Internet va lui permettre d’écrire ». (Benjamin Bayart) http://www.framablog.org/index.php/post ... ture-seule
Avatar de l’utilisateur
maybe
Maître Libellulien
Maître Libellulien
 
Messages: 608
Inscription: 02 Déc 2008 10:04
Localisation: ailleurs

Re: [RESOLU] Le service Stockage amovible ne démarre pas

Messagepar zardoz35 » 25 Juin 2009 05:33

Fait.
C'est mieux pour l'indexation du sujet, tu as raison.

j'ai supprimé ImportDatabase dans la base de registres puis j'ai remis stockage amovible en manuel dans services.msc. Tout est ok
zardoz35
Libellulien Junior
Libellulien Junior
 
Messages: 109
Inscription: 13 Oct 2008 18:18

Précédente

Retourner vers Windows NT, 2000, XP

Qui est en ligne

Utilisateurs parcourant ce forum: Aucun utilisateur enregistré et 0 invités