[résolu] Problème de transparence des .png sur IE/Maxthon

Ce forum vous permet de communiquer et d'échanger avec d'autres, votre point de vue sur la photo numérique. Partagez vos connaissances et vos émotions, vos questions sur l'image et son traitement, le dessin vectoriel, etc...

Modérateur: Modérateurs

[résolu] Problème de transparence des .png sur IE/Maxthon

Messagepar septi¢ » 07 Mar 2006 15:49

Bonjour à tous

Voici mon problème, il est surement tout simple mais il m'énerve passablement vu mes connaissances limités en la matière.

J'utilise donc un .png comme avatar, dont l'arrière plan est donc censé être transparent et donc se meler à la couleur de fond du forum, mais depuis quelque temps, peut importe le forum sur lequel je suis, l'arrière plan de mon avatar est d'un espèce de bleu/vert, une idée pour qu'il redevienne transparent ?

(pourtant que j'affiche le .png dans les progs de retouche image etc, c'est bien transparent)

Merci d'avance.
Dernière édition par septi¢ le 08 Mar 2006 00:24, édité 1 fois.
Image Flugulbru zuik pluttz mekp ? khuil plop mek fiut !
Avatar de l’utilisateur
septi¢
 
Messages: 7
Inscription: 07 Mar 2006 14:19

Messagepar Falkra » 07 Mar 2006 15:53

Bonjour, et bienvenue sur le forum. :-D

Il est chouette cet avatar, et sous FF je le vois... transparent (arrière plan), comme tu le veux, par contre avec IE je le vois en fond gris.

Il peut s'agir du bug IE ave le format PNG, pour corriger cela, essaie d'utiliser ce programme :
PNG optimizer, qui permet de corriger cela, et optimiser le fichier, sans en altérer la qualité.


Update : j'ai fait le test rien à faire, en fait c'est IE6 qui ne supporte pas la transparence en alpha channel (seulement accepté depuis la version 7 beta1).
Donc à moins de passer à ie7 ou Firefox il va falloir utiliser le gif... mais c'est moins bon (256 couleurs seulement + dither réglable, ce qui pose le problème des contours).
Avatar de l’utilisateur
Falkra
Admin libellules.ch
Admin libellules.ch
 
Messages: 25882
Inscription: 30 Jan 2005 13:44
Localisation: 127.0.0.1

Messagepar septi¢ » 07 Mar 2006 16:28

Ok, merci beaucoup pour la réponse rapide

J'avais effectivement utilisé PNG optimizer de toute façon, ne serait-ce que pour respecter la limite de taille en ko pour la plupart des forums, mais rien n'y fait, et je comme je n'ai absolument pas l'envie quitter Maxthon pour un autre navigateur... :)

Ceci dit, je n'avais pas se problème d'avatar avant, enfin il me semble que sur certains forums, la transparence avait fonctionné, mais je ne suis plus sûr de rien maintenant vu ce que tu viens de me dire.
Image Flugulbru zuik pluttz mekp ? khuil plop mek fiut !
Avatar de l’utilisateur
septi¢
 
Messages: 7
Inscription: 07 Mar 2006 14:19

Messagepar septi¢ » 07 Mar 2006 17:24

Desolé, une dernière question :) : Pourquoi cela marche sur ce forum ? qu'est ce qu'ils ont fait de spécial ? :

http://www.trucsenvrac.com/forum/forumd ... php?fid=95

(j'ai décidé de reposter le sujet lorsque j'ai vu que ça fonctionnait chez eux.)
Image Flugulbru zuik pluttz mekp ? khuil plop mek fiut !
Avatar de l’utilisateur
septi¢
 
Messages: 7
Inscription: 07 Mar 2006 14:19

Messagepar PhilFree » 07 Mar 2006 17:30

septi¢ a écrit:comme je n'ai absolument pas l'envie quitter Maxthon pour un autre navigateur...


Salut septi¢

En fait Maxthon est un simple clone de IE, il est bati sur le moteur d'Internet Explorer.

Donc comme IE a un bug de traitement des PNG transparents, Maxthon l'a aussi.

Et tu n'y peux rien :roll:

Enfin si, tu peux utiliser FireFox :lol:
Avatar de l’utilisateur
PhilFree
Super Libellulien
Super Libellulien
 
Messages: 1753
Inscription: 21 Nov 2004 12:59
Localisation: Somewhere over the rainbow

Messagepar Falkra » 07 Mar 2006 17:39

Re. J'ai analysé l'image sur l'autre forum, et comparé les fichiers, ils sont différents, j'aurais parié que l'autre n'était pas paramétrée en transparence "alpha channel", mais en "single color transparency", donc ça passerait sous les deux navigateurs, mais ne fait non.

En ouvrant la page du forum avec IE6 : (http://www.trucsenvrac.com/forum/viewthread.php?tid=7311) le fond apparait opaque une demi-seconde, puis devient transparent.

En ouvrant l'image (lien direct) sous IE6 (http://arnaud.sepa.free.fr/Photos/Avatars/super_man_100.png ça la montre opaque...

:arrow: Il y a quelque chose sur le forum probablement...
Avatar de l’utilisateur
Falkra
Admin libellules.ch
Admin libellules.ch
 
Messages: 25882
Inscription: 30 Jan 2005 13:44
Localisation: 127.0.0.1

Messagepar Falkra » 07 Mar 2006 17:43

Bingo, il y a deux façons de contourner la chose sous IE, c'est une histoire de syntaxe html, avec une certaine syntaxe la lacune d'IE est contournée (pas le bug, c'est encore autre chose si j'ai bien lu, quoi que rapidement)

Détails ici :
http://catinon.info/blog/2006/01/24/3-le-point-sur-les-png-transparent-sous-ie6
http://www.denturax.com/sutra6334.html
Avatar de l’utilisateur
Falkra
Admin libellules.ch
Admin libellules.ch
 
Messages: 25882
Inscription: 30 Jan 2005 13:44
Localisation: 127.0.0.1

Messagepar septi¢ » 07 Mar 2006 18:09

Oui, comme tu l'as dit et je n'en doutais pas, voici la réponse sur l'autre forum :

nobodyuse a écrit:Cela est tres simple !

La transparence du format PNG n'est pas gerée par Internet Explorer ou tout autre soft utilisant le moteur de IE (Avant Browser, Maxthon, ....)


Sur ce forum ca marche car nous utilisons un script special qui force IE à gerer la transparence



Je sais bien que Maxthon est une surcouche d'IE et qu'il à donc les mêmes bugs (quoique certains ont été fixés sur Maxthon si je ne m'abuse, faut pas me demander comment ;) ).

En tout cas, merci pour vos réponses, et je vais lire les liens de ce pas. :)
Image Flugulbru zuik pluttz mekp ? khuil plop mek fiut !
Avatar de l’utilisateur
septi¢
 
Messages: 7
Inscription: 07 Mar 2006 14:19

Messagepar septi¢ » 08 Mar 2006 00:23

Si comme moi il y a des utilisateurs de Maxthon par ici, sachez qu'il existe un plugin pour résoudre ce problème de transparence, je le laisse ici au cas où :)

http://tara.maxthon.com/index.php?act=view&id=439
Image Flugulbru zuik pluttz mekp ? khuil plop mek fiut !
Avatar de l’utilisateur
septi¢
 
Messages: 7
Inscription: 07 Mar 2006 14:19


Retourner vers Photo numérique, traitement d'image

Qui est en ligne

Utilisateurs parcourant ce forum: Aucun utilisateur enregistré et 0 invités