[RESOLU] Que faire des autres NET Framework?

La section des versions NT, 2000, et XP de windows : informations, problèmes, questions, avis ou dépannages y trouveront leur place.

Modérateur: Modérateurs

[RESOLU] Que faire des autres NET Framework?

Messagepar Gallilée » 03 Déc 2006 10:50

Bonjour,

J'ai installé la dernière version NET Framwork 3, et je me rends compte,que du coup, dans ajout et suppression de programme, j'ai plusieurs Net Framwork installés.

Je me demande, si je dois tous les garder, ou si je dois supprimer les anciens?


Image

Merci
Dernière édition par Gallilée le 22 Déc 2006 23:49, édité 3 fois.
Avatar de l’utilisateur
Gallilée
Super Libellulien
Super Libellulien
 
Messages: 1382
Inscription: 10 Nov 2004 21:19
Localisation: Ailleurs

Messagepar Achille1er » 03 Déc 2006 11:15

Ca doit être normal vu que c'est un produit microsoft pour un autre produit microsoft (windows) :-D

Si eux-même ne savent pas comment gérer ça, qui le sait ? :wink:

En tous cas, on ne peut pas reprocher à .net d'être un produit trompeur qui cache son caca :lol:
Avatar de l’utilisateur
Achille1er
Super Libellulien
Super Libellulien
 
Messages: 2533
Inscription: 30 Mai 2005 07:46
Localisation: Zotrland

Messagepar Falkra » 03 Déc 2006 11:21

Bonjour, je croyais que cela faisait double emploi, en fait non. J'ai appris ici et/ou par le blog qu'il faut laisser le 1 et le 2 installés ensemble. Le 2 n'est pas rétrocompatible (bravo !) avec les applications du 1. Pour le 3, je ne sais pas, mais je suppose (à confirmer) que c'est pareil...

Les autres entrées sont des mises à jour, à ne surtout pas retirer bien sûr. :-D
Avatar de l’utilisateur
Falkra
Admin libellules.ch
Admin libellules.ch
 
Messages: 25882
Inscription: 30 Jan 2005 13:44
Localisation: 127.0.0.1

Messagepar Gallilée » 03 Déc 2006 12:30

Merci pour les infos
Avatar de l’utilisateur
Gallilée
Super Libellulien
Super Libellulien
 
Messages: 1382
Inscription: 10 Nov 2004 21:19
Localisation: Ailleurs

Messagepar Airwave » 11 Déc 2006 07:47

Ben en fait cela dépend de ce que tu veux... Le Framqwork 3.0 apporte des nouvelles classes et de nouvelles interfaces, notamment pour le développement sous Vista.

Si tu développes sur cette plateforme ca peut t'etre utile, mais si tu es juste un utilisateur, installer la version 3.0 n'apporte pas grand chose, sachant qu'aucune application distribuée ne l'utilise encore...

Meme après l'avoir testé sous Vista, il faut encore installer 2 "packs" pour rendre Visual Studio 2005 compatible... la joie quoi...
Avatar de l’utilisateur
Airwave
Super Libellulien
Super Libellulien
 
Messages: 1321
Inscription: 21 Juin 2003 16:31
Localisation: Geneve

Messagepar Gallilée » 11 Déc 2006 15:04

Merci.

Mais, cela m'amène à me poser une question:

Framework, ce serait un truc pour les développeurs, donc, pour une utilisation courante d'un pc, on en aurait pas besoin, pas même la version 1 et 2?

Je me trompe?
Avatar de l’utilisateur
Gallilée
Super Libellulien
Super Libellulien
 
Messages: 1382
Inscription: 10 Nov 2004 21:19
Localisation: Ailleurs

Messagepar Achille1er » 11 Déc 2006 16:16

Les "executables" créés dans ce langage ont besoin de ces libraries pour fonctionner, même windows XP en utilise (peu, mais quand-même)...
Avatar de l’utilisateur
Achille1er
Super Libellulien
Super Libellulien
 
Messages: 2533
Inscription: 30 Mai 2005 07:46
Localisation: Zotrland

Messagepar Falkra » 11 Déc 2006 21:08

:+1anim:
Pour le moment, on a besoin du 1 et du 2, du trois un peu plus tard sans doute.
Avatar de l’utilisateur
Falkra
Admin libellules.ch
Admin libellules.ch
 
Messages: 25882
Inscription: 30 Jan 2005 13:44
Localisation: 127.0.0.1


Retourner vers Windows NT, 2000, XP

Qui est en ligne

Utilisateurs parcourant ce forum: Aucun utilisateur enregistré et 0 invités