Combiner plusieurs colonnes en utilisant la fonction CONCATENER

Combiner plusieurs colonnes Excel en utilisant la fonction CONCATENER

Supposons que vous avez plusieurs colonnes de données que vous voulez combiner en une seule colonne, comme par exemple, le titre, le nom, le prénom d’une personne. Pour cela, vous devez utiliser la fonction CONCATENER dans une formule à droite de la dernière colonne de données que vous voulez combiner.

Vous pouvez ajouter un espace pour séparer proprement les noms et les adresses dans la nouvelle colonne en les plaçant entre guillemets (" ").

Combiner plusieurs colonnes Excel en utilisant la fonction CONCATENER

Dans l'exemple ci-dessus, on utilise la fonction CONCATENER pour combiner le contenu des trois cellules A1, B1 et C1. Pour ajouter un espace entre les chaînes, incluez un espace entre les guillemets (" ").

=CONCATENER(A1;" ";B1;" ";C1)

Source: Aide Excel (F1)

Commentaires

1. Le vendredi, 24 avril, 2015, 10:22 par GM1968

Bonjour,
En écrivant =A1&" "&A2&" "&A3 ça marche aussi très bien, on peut mélanger des chiffres et des chaines de caractères... (depuis excel 4... voir même avant)...
GM1968

2. Le vendredi, 24 avril, 2015, 21:36 par PP

Bonjour,
Merci pour ce rappel intéressant.
Mais une petite question, si dans votre exemple B1 contenait la valeur numérique 2.100,00 (format numérique avec 2 décimales et séparateur de millier) comment peut-on lors du "concaténage" garder ce format.
MERCI, PP

3. Le vendredi, 24 avril, 2015, 22:58 par Starwolf20

Il faut utiliser la fonction TEXTE().
par exemple : =TEXTE(12000,501;"#.###,00") renvoie 12.000,50

4. Le vendredi, 24 avril, 2015, 23:00 par Starwolf20

=TEXTE(12000,501;"#.###,00") renvoie le texte 12.000,50

Ajouter un commentaire

Le code HTML est affiché comme du texte et les adresses web sont automatiquement transformées.

Fil des commentaires de ce billet