Thunderbird passe de la version 3.3 à la version 5

2009-02-27_115620.png

Mozilla viens de mettre en ligne la version 5 de Thunderbird.

Comme avec Firefox, Thunderbird passe de la version 3.3 à la version 5.

Les nouveautés incluses dans cette nouvelle version

  • un nouveau gestionnaire d'extension
  • un nouvel affichage pour les pièces jointes avec leurs tailles
  • les onglets pouvant se déplacer dans une ou plusieurs fenêtres
  • un nouvel assistant pour la création de compte courriel
  • une nouvelle page pour l'envoi d'informations pour les bugs et les problèmes
  • l'utilisation du moteur Gecko 5
  • des corrections concernant les thèmes pour Windows Vista et 7
  • l'intégration des plugins dans les flux RSS
  • la correction de 390 problèmes de sécurité, de performance et de rapidité

La mise à jour se fait via votre version actuelle de Thunderbird

home2.gif ou via le site officiel

home2.gif Note version 5

Commentaires

1. Le mercredi, juin 29 2011, 16:52 par Falkra

Cette manie de coller de la transparence en haut (W7), pouah.
Bon, ça a l'air d'aller chercher les e-mails et d'en envoyer, ouf. :)

2. Le mercredi, juin 29 2011, 17:38 par dante

Et toutes les extensions, j'en ai peu mais bon, qui seront pas compatibles....pouah en effet....j'hésite...

3. Le mercredi, juin 29 2011, 20:40 par Falkra

Je copie-colle mon laius issu de Firefox, même principe. Si vous l'avez déjà lu, zappez ! ;)

La compatibilité des extensions, ça fait souvent râler, mais c'est souvent imputable aux développeurs en fait.
Les fichiers XPI sont des ZIP renommés. Dedans vous avez un fichier install.RDF en mode texte qui contient les indicateurs de version. Certains développeurs n'utilisent pas assez les étoiles * pour assurer une compatibilité ascendante, notamment pour les extensions qui ne sont pas touchées par les changements sous le capot de Thunderbird, qui nécessitent une réécriture du code.
La plupart du temps les développeurs ont juste à changer le numéro de version dans le fichier RDF (on peut le faire, nous, pour rendre compatible une extension, tant que son code n'est pas à récrire, ça passe). Du coup souvent c'est fait sur le site du développeur, où la version est plus récente, mais pas sur addons.mozilla.org et les serveurs de mozilla pour les mises à jour automatiques, le temps de refaire une validation sans doute.

4. Le mercredi, juin 29 2011, 23:12 par dante

Merci pour cette explication Falkra! On peut y modifier nous-même?

5. Le jeudi, juin 30 2011, 07:24 par wullfk

@dante;

comme la dit Falkra, tu peux le faire si le code n'a pas été réécrit, je l'ai par exemple fait pour l'extension Firefox :
Add N Edit Cookie qui sur le catalogue Mozilla n'est pas compatible FF 4.0 et encore moins FF 5.0
la modif est très simple en soit, il suffit après rapatriement du fichier .xpi de l'ouvrir avec par exemple WinRar
puis faire un clic droit sur le fichier install.rdf , sélectionner "visualiser"
rechercher la ligne : à la ligne <em:maxVersion>3.6.*</em:maxVersion>
Changez la version max en mettant 4.0.* ou plus
la fonctionnalité visualiser ne permet pas à ma connaissance d'effectuer la modification, le mieux est donc d'éditer ce fichier avec le bloc note Windows ou avec l'éditeur qui vous convient le plus, mois j'utilise Notepad++

Attention ! tout de même, utiliser cette astuce en connaissance de cause, car celons les modules elle ne fonctionnera simplement pas, ou alors elle plantera votre navigateur.

6. Le jeudi, juin 30 2011, 09:11 par Falkra

Voilà. Le tout c'est de pouvoir dépatouiller le truc en cas de pépin.

7. Le jeudi, juin 30 2011, 15:21 par dante

Bonjour Falkra et Wulfk,

en effet cela semble compliqué, mais j'ai essayé et cela s'ouvre facilement. Mais il y a plusieurs lignes <em:maxVersion>, cela ne concerne que celle avec le * ? Puis y enregistrer? Bref, j'ai réussi la manip pour y ouvrir et visualiser, merci pour me l'avoir expliquée. Mais comme dit Falkra en cas de pépins...? C'est peut-être mieux que je laisse le tout sans y modifier et j'attends que certaines extensions deviennent compatibles ou des nouvelles.

En tout cas merci pour vos explications!

8. Le vendredi, juillet 1 2011, 16:13 par nazoreen

Bon il à l'air sympa sauf pour la consommation mémoire x4 par rapport à la version précédente... bref il a pris le défaut de Firefox 5...

9. Le samedi, juillet 2 2011, 13:48 par Falkra

Tout dépend du noyau (version de Windows) du nombre d'extensions, et du nombre de mails en stock, cela influence aussi la consommation mémoire. On peut dégager des tendances, mais pas des règles absolues en la matière. Avec 4Go de ram, peu m'importe finalement. Outlook je passe. ^^

10. Le mardi, juillet 26 2011, 13:24 par 1suisse

merci pour l'info concernant tb5.

bon ben je vais mettre à jour les guides de configuration infomaniak :)

Ajouter un commentaire

Le code HTML est affiché comme du texte et les adresses web sont automatiquement transformées.

Fil des commentaires de ce billet