Firefox 6

logo_firefox.gif L'attente aura été de courte durée, puisque deux mois seulement après la sortie de Firefox 5, c'est la version 6 qui est proposée dès maintenant par les mises à jour automatiques.

Mozilla poursuit sur sa lancée, et modifie sa façon de numéroter le navigateur, cette version pourrait être une 5.1 ou 5.2, les changements ne sont pas majeurs. Mozilla semble vouloir rattraper les autres au niveau des numéros de version, une version 6, 7 ou 9 donne un aspect plus abouti qu'une version 4.8 sans doute.

Parmi les nouveautés, un affichage modifié pour les noms de domaine dans la barre d'adresse, dans la continuité de la protection contre le phishing, une nouvelle page (about:permissions) pour gérer les mots de passe stockés, la géolocalisation (désactivable) et les cookies, site par site. On attend une amélioration des performances au passage, tout dépendra des sites et de vos machines, et vous pourrez justement jeter un oeil à la page about:memory pour en apprendre plus... enfin si vous digérez la façon dont tout cela est affiché. On parle dans la presse de version pour les développeurs, ce n'est pas pour rien, de nouvelles fonctions sont là pour eux. ;)

En attendant, vous pouvez faire cette mise à jour tranquillement, la plupart des extensions ont déjà franchi le cap, si elles sont bien programmées.

La suite ? Un Firefox 7, plus rapide, gérant mieux la mémoire et orienté synchronisation avec les téléphones portables, en plus du reste. Firefox 8 pour le moment devrait proposer encore plus de performances, le développement étant axé sur la vitesse et la mémoire.

Site officiel

Commentaires

1. Le mardi, août 16 2011, 22:42 par Li-An

La plupart, ah ah ah, je rigole. Les extensions qui font que FF est toujours bien installé chez moi (Drag and Drop upload, Save image in folder, Feedly et autres) ne sont pas à jour. On attendra un peu avant de passer à FF6.

2. Le mercredi, août 17 2011, 00:42 par tomette

Malgré ma 50ène d'extensions - je sais.^^.., j'ai upgradé à FF6 sans problème. Je n'ai que 3 extensions d'incompatibles.

Mais, grâce à "Is it compatible?", je savais AVANT la mise à jour jusqu'à quelle version chaque extension /thème est compatible. Donc, bien utile, à mon avis.

"checkCompatibility" porte bien son nom et évite que les extensions incompatibles ne se désactivent pas malgré la vérification de FF. Donc, encore plus pratique, laissant le temps soit pour les développeurs de mettre leur "bébé" à jour, soit pour vous de chercher une autre extension ressemblante.

3. Le mercredi, août 17 2011, 05:37 par BYP

Installé ce matin... So far so good, tout semble fonctionner comme avant.
(En fait, il n'y a pas de raison pour que cela ne fonctionne pas comme avant...)

4. Le mercredi, août 17 2011, 07:12 par Falkra

Li-An, chez moi tout est passé nickel. APrès, tu connais le problème, qui vient des extensions : si les développeurs oublient de mettre "compatible 6.*"avec les étoiles, c'est eux qui les rendent incompatibles.
Si ça presse, télécharge l'extension, renomme le XPI en ZIP (c'est un zip renommé...) localise le fichier "install.rdf" dans le zip et édite les versions pour rendre compatible.
Si rien de majeur n'est à reprogrammer, ça passe.

5. Le mercredi, août 17 2011, 11:59 par Max Planc

Pour ma part je tourne depuis plusieurs mois avec la version Aurora (7.02a) et j'en suis très satisfait.
Certes il y a encore quelques petits problèmes d'incompatibilité avec des modules mais rien de bien mèchant, je peux m'en passer.

6. Le mercredi, août 17 2011, 14:47 par Li-An

Oui, je connais bien le concept de modif de version max c'est juste casse pied à faire :-) Je vais déjà voir check compatibility.

7. Le mercredi, août 17 2011, 15:01 par Falkra

Ca, le côté casse pieds, je te l'accorde volontiers, tu as raison. ^^
Bon, après je suis un peu obligé de le rappeler pour les lecteurs non habitués.

8. Le mercredi, août 17 2011, 16:58 par wullfk

sur une config avec 44 extensions d'installé, seulement 5 d'incompatibles pour le moment
Capture Web Evernote
Malwares Search
Save Image in Folder
Web2PDF
Java Console 6.0.26

à première vu ça ma l'air plus rapide
bien vu en tout cas pour les pages about:permission et about:memory

9. Le mercredi, août 17 2011, 17:01 par wullfk

petite précision entre la version 5.0 et 6.0 entre temps il y a eux la version 5.0.1, bizarrement il m'a fallu lancer le setup pour l'installer alors que pour la 6.0 c'est proposé en mise à jour.

10. Le mercredi, août 17 2011, 19:33 par Falkra

44 extensions ? O_o
Ca tourne vite ?

Pareil pour la 5.0.1, qui venait sans doute préparer le téléchargement de la 6, et soit ils ont oublié un truc soit le serveur nous a oubliés nous pour la màj auto, je ne sais plus. ^^

11. Le mercredi, août 17 2011, 21:54 par tomette

@ Li-Ann :
peut-être que vous devriez consulter "Add-on Compatibility Reporter" également extra pour ce genre de cas et vous conviendrait mieux : elle applique la mise à jour même s'il y a des extensions incompatibles (à la base, pour les développeurs, je crois). Si jamais trouvable :

- pour FF ici : https://addons.mozilla.org/fr/firef...

- et/ou pour Thunderbird ici : https://addons.mozilla.org/fr/thund...

@Falkra
non, non, toutes ces extensions ne me pausent aucun souci de lenteur ou autre et tout roule parfaitement. Je sais, c'est énorme, mais toutes me sont très utiles, alors ^^...

12. Le jeudi, août 18 2011, 07:51 par Falkra

Ceux qui utilisent- CookieSafe ou CS Lite ont eu des déboires je pense avec les différentes mises à jour.
Il a fallu repasser au CookieSafe tout court, revenir, éviter le bug où le menu était invisible, etc.

CS Lite compatible FF6 est ici :
https://github.com/infinity0/xpi-co...

13. Le jeudi, août 18 2011, 15:03 par wullfk

hum! pour CS Lite y a eu une grosse bourde de commise par le développeur, en rendant précipitamment l'extension compatible à la sortie de FF 4.0 sauf qu'elle ne fonctionnait pas. (je sais pas ce qu'il en ai maintenant)
du coup pour ma part je me suis orienté sur CookieMonster , que j'ai fini par installer sur toute mes autres configs (WIndows ou Ubuntu)

note en passant, les dépôts FF 6.0 pour Ubuntu ont été rapidement mis en ligne , contrairement à la version 5.0 ou il a fallut attendre quelques jours.

14. Le samedi, août 20 2011, 07:11 par Falkra

En fait le menu ne fonctionnait pas, ce qui est... gênant. Et toujours pas, sauf par le lien donné, qui propose une version fonctionnelle.
Je n'ai pas essayé CookieMonster, mais si c'est sur le même principe, impec, ça fait une solution de repli. :)

15. Le dimanche, août 21 2011, 11:12 par waccobob

Hello,
toujours "Java console 6.0.26 incompatible avec Ff 6" donc désactivée. Chez vous aussi?

16. Le dimanche, août 21 2011, 13:32 par Falkra

Bonjour Waccobob, chez moi aussi oui, mais vu l'utilité pour moi de la chose, je le vire.

17. Le dimanche, août 21 2011, 19:10 par waccobob

OK, merci Falkra!

18. Le jeudi, août 25 2011, 08:55 par corinne

Parfois les extensions mises à jour sont disponibles sur le site de l'éditeur. il suffit de les télécharger.
J'ai résolu des problèmes d'incompatibilité comme cela (par exemple hyperwords).

Ajouter un commentaire

Le code HTML est affiché comme du texte et les adresses web sont automatiquement transformées.

Fil des commentaires de ce billet